Dual 4k Monitors with PowerExpand Elite 13

I’m looking for some troubleshooting advice. I have the new PowerExpand 13-in-1 and it’s working great except for the dual monitors. I have two 4k monitors plugged in via USB-C and HDMI. However, the USB-C monitor is always downscaled and I cannot get display preferences to show it’s full resolution options. I tried an Anker Thunderbolt USB-C cable w/ no luck. I also tried the monitor on another computer without any issues, so I know it’s something with the dock or cabling setup. Any suggestions?

Did you ever figure out what the issue was? I am dealing with the exact same problem.

I feel for you. The simple answer is no. I called Anker several times and they even replaced the unit 2x. Ultimately they said it wasn’t a supported scenario. Tricky wording in the advertising, in my opinion. It supports dual 4k monitors. It doesn’t support outputting dual 4k signal. I went with CalDigit and it works wonderfully with no headaches.

If you used just the USB-C monitor and not the HDMI port at all, could you get 4k at that point? Just curious what the limitation is.

I tried different permutations using USB-C, HDMI across each. In every case, one of the outputs was downsample’d