Drop sensors are dirty error, but they are CLEAN, HELP!

Eufy Robovac 30c, two of them, one purchased June 2019, one purchased March 2019. Run daily.
Both of them are now, every time they run, giving the “Drop sensors are dirty” error at some point in their cycle. When I get home from work, they are just sitting dead in the middle of a room. Not stuck under anything, not hanging over any stair edges, just in the middle of a carpeted room, stopped, shut off. Without doing anything to clean them, I press the start button and they finish their cycles without any further errors.

I clean them after EVERY run - empty the dust bin, wipe the sensors, clean the roller, clean all the wheels. Every other week, the filter media gets washed, dust bin washed, entire vac wiped down with soft cloth.

These vacs have been babied, yet they are now both giving this error every time they run.

Is there any solution to this? It really defeats the purpose of being able to run them when I’m not home.

1 Like

Open the battery case.
Remove the battery and insert it again after a minute.
This is a kind of reset.
May be this helps.

I’ll give it a try, thank you.

I contacted support with this information, and they suggested that I SMACK the bumper, really hard, since there are sensors under there that might be dirty. I wasn’t too comfortable with abusing the vacs like that, so they also suggested that I could remove the bumper to clean underneath it.
I ended up cleaning the whole vac using compressed air instead. WOW did that ever blow a lot of dust out from the wheel cavities and from under the bumper.
Today, the vac ran its full cycle without any “drop sensor dirty” errors. Hooray!

Welp. That only worked for exactly one cleaning cycle. Next cleaning cycle, both vacs stopped within 5 minutes of starting with a dirty drop sensor error. Took the bumper off, it was completely clean under there, as were the drop sensors. Time to escalate this with support.

Have you tried the reset by removing the batteries?

gah! Not yet. I got sidetracked with the cleaning. I did try to remove it, but the connector would not let go, and I was too lazy to go find pliers to help me with it, so I went the cleaning route.
I’ll give it a try and see if it makes a difference.
FWIW, I just checked and today’s cleaning cycle ran without issues, so I guess this is something intermittently annoying.

Give the robot more a chance.
Ultima ratio would be to remove the batteries.
Unplug. There is nothing you can do wrong! :smiley:

So far, so good - both vacs completed cycles without drop sensor errors today after having had their batteries unplugged/re-plugged.
Let’s see what happens tomorrow!
Thanks for the tip :slight_smile:

I have the same problem, and I just got the 35C yesterday. In one day it is doing the 3 beep error. NOt like I live in squalor for it to have its sensors get dirty in less than 24 hours. I unplugged and removed the batter for a minute as well, but that too didn’t do anything. Help!!! Am I just better of returning it?

If you really sure there is nothing stuck in the front sensor (bumper) you should contact the support.
Best is to add a video, better that 1000 Words often.

1 Like

Thanks for your reply. Pretty sure there’s nothing stuck. And I just got this yesterday. Is there a way to open the bumper and clean it? Do you know?

1 Like

If you got it yesterday do not open.

This way you would kill the warranty.

Make really sure the front bumper is free of any things
After done this, you should contact the support for further steps to solve the issue , which ist not normal.


Thanks. I have already emailed support. I hope they get back to me soon. Otherwise I would have to return the product.

Wait for their answer.
Should happen next week.
Your RoboVac is under warranty so the issue should get solved next week by the support.

I was having same issue and saw in another Q&A that it may be due to strong sun reflecting off of the floors. I closed my curtains and have had no more issues


Ja, that’s a probable reason.
The sensors are sensitive if the robot changes from “dark” to “bright” areas.
I have seen the same behavior of my “old Willy” (now about more than 2,5 years old)
Will never learn it! :rofl:

I keep having exactly the same problem. I had emailed them in the past, but it was of no help at all. Since I don’t have a warranty anymore and there is no eufy service center in my country, I decided to try solving it by myself, and I completely deactivated the drop sensors. Unfortunately, even if the drop sensors were deactivated, after a few seconds that my robot started working it stopped again. The error message was once again the same “drop sensors are dirty”…I really don’t know what else to do beside throwing it in the garbage and buying a new one. I haven’t used it enough and for me this purchase has been a waste of money. So disappointed

Is there any way to reset the sensors?

Have you tried a reset by removing the battery and insert it after a minute?
How did you deactivate the sensors?