Doorbell connection issues

Ive had my Eufy doorbell for maybe a year now. I have always had to wait for the video to load. It’s not like I could be out walking the dog and the doorbell rings and I could interact with whoever it was. I’d have to watch the little Eufy arrow circling while “Preparing to play”.
Sitting here in my living room I get the message Cannot connect to the doorbell (-3). When the live camera does connect, I can see the kb/s reading but after a few second it stops updating and stays at zero.
If I try to restart the device I usually get a Restart Failed message and something about my internet connection is not stable enough. There’s an annoyingly long delay between when the mailman shows up and my fone lets me know. Its even difficult to watch or delete the recording. It’ll start but then freeze up.
In the past couple of days I replaced the ordinary doorbell transformer with a 24vac 650ma wall wart so I know there is sufficient voltage. I have a wifi extender about 5’ away from the doorbell so it cant be too far out of range. I’ve reinstalled the app on my fone. Not much changes.
This is aT8200 doorbell running firmware version 2.317.
Just tried to do a restart and it’s been showing Doorbell is Offline for about 15 minutes. Not sure if that’s normal, guess I’ve never seen a restart before.
I cant think of anything else to try.
Anyone have any suggestions?

Have you tried resetting it? If that doesn’t work you can always reach out to support

Can you move the Homebase a bit closer to improve the connection?

1 Like

This is what I would have suggested as well. :grinning:

There is no homebase for the doorbell. My wifi repeater is located only 5’ away from the doorbell. Should not be necessary though because my wifi signal reaches all over the house and out to the garage.

Thanks for reaching out.

For the Doorbell offline, most likely this is the result of your Doorbell losing connection to the Internet.

Please check if Doorbell is disconnected from your Wi-Fi router; you can do this by checking to see whether the LED on the Doorbell lights blue or not. If the LED lights red, reconnect your Doorbell to Wi-Fi again.

You should also check to make sure your router has access to the Internet. Please be assured we always stand behind our products and want to make this right for you.

If the issue still persists, please contact

1 Like

Hello @Carlos14, I have the same issue as you and I was just told by Eufy Support that their product is NOT compatible with a Wi-Fi extender or a repeater. There is no other solution to resolve this problem except to move your Wi-Fi router closer. As you stated, there is no homebase for your doorbell. My only suggestion at this time is to post here at the forum and ask Anker Product Management team to update the firmware for your doorbell and other Eufy products to be compatible with Wi-Fi extenders. Maybe they will listen to customers’ requests. Good Luck.

You can fix this by resetting the connection, may be it will help!