Does the "check for firmware update" button DO anything?

Can someone please explain how, if device updates have been out for almost a week, the “check for firmware” buttons for cameras and HB constantly tell me I’m on the latest version when I’m clearly not? Or am I just “doing it wrong?”

1 Like

So, what firmware version you are on your eucycam and homebase currently?

Cameras are 1.7.8 and HB is I’m not dying for an update, necessarily, just wondering how that “feature” actually works. My assumption is it’ll only work if the (regional?) server it hits has the update available for download, but it seems a little disingenuous otherwise.

@Crownfox As to the “check for firmware” buttons, please note it can check the latest firmware version automatically. We are releasing HomeBase v1.0.7.9 and eufyCam v1.8.0 for our us users currently, please stay tuned!

@AnkerSupport still confused :confused: can we find and force firmware update using this button in app?

Damn :angry: that 500 Error strikes again :anger_right:

Just updated here. Not easy, but after a few times it worked. Cam is on 1.8.0 and HB is on

It eventually worked for me, as well, but better documentation/explanation seems to be in order. For example, if someone knows an update is out, because other users have it, it’s a reasonable assumption that pushing that button forces a pull request on the update, so when it comes back with that “latest version” message, it’s super frustrating.

Hope this will be part of next upgrade :thinking:

Does the “check for firmware update” button DO anything?

This should answer your question! :smile:

(Hint: Double click the image to see it max size and readable)

We tested this on a cam here in the office, and after hitting this button to update, the cams and homebase do update. It took around 15 minutes for the versions to show up.

What versions of hardware and app were you on when you did the test? I ask because I tried updating both cams and HB several times over the course of 3 days after I’d read reports from people who’d already been updated (via push method, rather than the pull of the update button).

Also, did you get the message that the firmware was already updated and then the update happened 15 minutes later, or did you get a message it would update and it just took a while to occur? My experience was I constantly got the message I was on the latest firmware versions, even though I wasn’t, for 3 days.

This was something that was happening to a few customers - 2-3 days for the update to show as updated. Glad to see you’re all updated though!