Disney plus app stopped working suddenly on Nebula capsule Max

Hi, got an odd issue with Disney plus app on my Nebular capsule Max. Disney plus suddenly stopped working, the app loads, I can login and all options show normally but when I select something there are no options, if I choose STAR WARS I just get a bit picture of the death star and nothing else, nothing further to select or click on, same with marvel or individual titles.

I’ve tried:

1 reboot - no change

2 wiping cache - no change

3 wiping data fully and relogging on - no change

4 removing the app completely and reinstalling from scratch - no change

5 downloading and sideloading app - no change

Disney app is not available on google play store, this has worked for several weeks with no issues, the app continues to work on my Android phone, tablet and windows PC no issues. All other apps also seem to be ok on my capsule.

1 Like

An app stopping working on Nebula is inevitable, it is not a mainstream product from the app developer’s perspective, chances are the service owner changed something their end, and the Nebula is not updated to match, so doubt it will work again.

More things will break.

Workaround for a permanent solution is to buy an HDMI connecting something which is mainstream, something popular like a Chromecast or whatever matches your needs.

These niche products with Android are doomed, not enough sell to make it worthwhile the app owner to keep working. Just enjoy it while it works, knowing at least you got HDMI way out.

You can attempt to email Nebula support, they may know a fix. The typical fix is they know a version which works and pre-load that last known good working version, and disable play store updates as newer versions won’t work, but that only works so long as eventually the app needs updating and the projector’s DPI and resolution don’t get supported updates.

Ideally you know this at purchase time and factor into the decision, much better than assuming something sold only in the hundreds to thousands will keep working while devices sold in the millions move on.

If you’re wondering exactly what is at fault, it probably is the DPI. To support higher spec newer devices they update the backend to support newer DPI. But those newer DPI devices have more pixels than these low resolution projectors, so you find the image is either not working or you see just a corner of the image. All projectors with built-in Android are doomed, it’s not really Nebula fault but the fault of those who just assume because it works today it will keep working. A dumb projector not running Android, if it’s lower cost but otherwise works well, is a better choice. If you do insist on buying an Android projector just be grateful for what works while it works.

Further, all existing Android devices have a similar issue in that the manufacturer supplies updates only so long, then the app stops working on the older Android. Most Android devices can be unlocked to work on newer Android but the unlocking breaks DRM so encrypted content doesn’t work.

Apple does a similar thing, they stop supporting older devices, then websites or apps won’t support.

The longest living thing is Linux but eventually some content requires a hardware feature which doesn’t exist and even Linux devices become less and less workable.

Everything dies. But a niche Android devices dies fastest.


if that were the case I would have expect more people reporting this on the forums, I seem to be the only one right now, i’ve only just bought this brand new from anker so i’ll be returning it if that is the case as if I wanted a none smart projector there were many cheaper options available.

1 Like

Not many sold. Not many use Disney Plus.

Judge the projector on picture and sound quality and any features not related to app support. A dumb projector may be worse in other ways so only compare with similar performance.

I have this projector, I had to sideload iPlayer and use it for iPlayer, Netflix and Prime Video and playing MP4 files off USB. Works for me. I like the size, battery and speaker.

Have you emailed support? They may know a fix.


1 Like

Hi yes i’ve mailed support, waiting for an answer.

I would say app are core usage for a android based projector, its unacceptable for them to be selling this still if apps are going to start losing support. just hoping its a glitch.

I’ve also tried plugging in a PC, fire stick, google dongle and even NVIDIA shield, each of these have their own issues I wont bore you with, I prefer the one device simplicty of this thing, its meant to be portable, you should not have to stick other stuff in it get access to popular apps.

i’ll be returning it if support for this app has folded already as i’ve only had it two months and they are still selling these brand new, or i’ll ask if they will swap it for the V2

1 Like


It looks like it either never worked or is problematic.

So Disney+ is not preinstalled? So you installed it yourself? So you asked for Nebula to unlock to enable Play Store? Well the Play Store will install some DPI version that is unrealistic for a low resolution projector, so I’d go to play store and disable auto update, then uninstall, then go manually via a PC and a usb stick each of the DPI versions in turn.

Well there’s usually a DPI and a no-DPI version.

So you should uninstall and install in turn each DPI version. IF neither works go back to earlier versions and try each DPI in turn.

I see

I see an Android TV version, the Max is Android not Android TV so try the other versions.

My guess is you need a no-DPI version so

Try both versions the DPI and the no-DPI version.

The challenge is the projector has a lower DPI than regular devices like phones and tablets so eventually the size of the borders and text will make the video stop working, if not now then eventually.

I also have hit and miss experience. The best outcome is a new high end tablet which supports HDMI out, runs everything. The Capsule Max cannot play Channel 4 without Play support so I gave up. Netflix does work but it’s a specific version preinstalled so I’m expecting it to break sometime. iPlayer worked. I got Channel 4 to work via sideload Firefox and run in browser.

The premise of a portable Android projector is going to be always awkward as its niche and the software is only tested on the big popular devices like Apple, Samsung, Pixel, Chromebook and browsers.

Speaking of which did you try Firefox and full screen browser? Works sometimes.

Avoid the Play Store, it will auto update from a working version to a non-working version, unless you install, disable auto update and uninstall before sideload. When you install via USB stick you have manually decided the version and it stays on that version until you do something. You’d then obvious never update an app untill the app is broken, then you’d try each subsequent version in turn til you find a version which works. What the app developer does is test only popular platforms, and waits for someone to flag a bug before fixing in the next release. So you have to bypass being experimented upon by the developer by manually installing and manually upgrading only when forced by a real bug for you.

I like that it runs Vanced App - ad-free youtube, that is better than a Chromecast which runs official with-ad version. The best way overall is a Chromebook with HDMI or modern Android tablet with HDMI support. My portable media device is a 10.8 inch tablet. Using it now.

1 Like

I noticed something today, if I scroll down to a movie that I have played before, if I click on it and scroll down two more pages I get the option to play it, this could in fact be a DPI issue but I’m using the app from the Nebula store so this should not be happening, I may have to do a full reset after all, i was trying to avoid this as it takes ages to fully setup with all my apps and stuff. I’m going to wait until Nebula come back to me first though I think.

1 Like

So my Capsule Max, I had indeed fiddled with it so much experimenting, I did a full factor reset twice.

What I learned was to

  • not replace the built-in app, as they have either tested and picked statically one known to work build. I dont use Disney but do use Netflix and installing another Netfix sideload broke it.
  • not install play store
  • sideload and try and if doesn’t work then uninstall
  • Use Firefox as a fallback, seems to work for everything
  • Use Vanced App instead of youtube

Disney is not that popular so if you are using the supplied Disney app from the Nebula store then Disney must have changed something their end and Nebula either doesn’t yet know (until you told them) or they do know and working on a fix. Either way you are right to wait for Nebula to respond.

Try Firefox. It has its own foibbles, I had to bluetooth pair a keyboard, and then used Firefox sync to get access to passwords etc. Login to Disney and then full screen, it might work. Might be my imagination but picture quality seemed better.

If Disney is indeed a deal breaker for you, of course you can do a factory reset see if that fixes Disney, if doesn’t work then you have your case to return. In my case as I had downloaded only Firefox, Vanced, iplayer , my setup after reset was not much.

What’s that?

There isn’t one that I’m aware of, they’ve done bigger brighter and more expensive versions but no logical successor to the Capsule Max, that I’ve noticed.

1 Like

I do have play store installed but the disney app isnt on it, you can only install it from the nebula store or side load it, I also tried to side load it and it made no difference.

I’m reluctant to do a hard reset as it takes ages to setup, this had been working for weeks with no issues, nothing has changed, one day it worked, the next it didnt.

1 Like

Well a good use of time while waiting for Nebula support to reply is install Firefox. It will probably play Disney, as I found it worked for me for everything. Even if Nebula Disney does get to work, Firefox is a useful Plan B.

I think its the arm64bit version, if not then the arm32bit.

Also if you not yet tried then try

This is technically superior to casting as you can use Firefox uorigin and Vanced ad-free.

It is slightly faster if you pair a bluetooth keyboard first as it speeds up typing email address and password faster to login for setup.

So logically, if you didn’t sideload nor Google Play, then either

  • Nebula had pushed an update which doesn’t work which means they didn’t test it. That feels illogically rash so I think unlikely.
  • Disney changed their back-end so now it doesn’t work with this version of app on Max. This is more likely. The answer may be “tough” in fixing it.

If a deal breaker then return but I encourage to try Firefox as you may like or prefer it.

1 Like

the capule 2 is the same but with google/android TV built in

nebular support got back to me with a sort of fix, they have uploaded a new version to the nebular store. This now has all the main menus back but when when I select a movie i still just get a full screen image, however I can now drag this down with my own AIR MOUSE (doesnt work with provided remote) to see the play button.

It looks like me their devs are using the wrong DPI in their app, i’ve let them know but at least I can use it again now :slight_smile:

1 Like

thanks yeah, i’ve been using vanced for ages, I cant use youtube on mobile without it now, its covered in ads

1 Like

Air mouse? You mean the Nebula connect app in mouse mode?

I’d say my Capsule Max is probably the worst value product I own. It fills a niche but I intend to use for many purposes, basically due to a self contained portability, I have family members visiting and can move it to any of their bedrooms with a screen, so it replaces 2 or 3 screens.

May leave it on Vanced projecting Xmas songs playlist list in the house pointing to a wall.

But given the brightness, resolution, and patchy support, it’s up there are one of the most “meh” products.

£330 now. I’d not deem it a “must buy” til around £199. £330 can get a lot of LCD screens. 42" is basically free now, people will give them away for free to not go to electrical disposal site, I was offered 55 inch for £30 recently. Use a Chromecast or HDMI cable off Chromebook.

Price of Chromebooks dropping now, that and a dumb projector would make a good portable system? Chromebooks have very good battery life and bright 13 inch screen…

Hi! The same happens to me with Disney Plus, whenever I want to see a movie, I click on it and it appears just as an image. But I discovered that if I play it first on my phone and then go back to the Max, I can continue watching it. I’ve been doing this for now, but I don’t know if there is any real solution.

I’m going to install the app again and see this new version you mentioned.

Thank you!

1 Like