Disney+ App stuck in update loop

Hello, I installed the Disney+ app on my Anker Nebula beamer through the Android store. Now the app won’t work, because it is stuk in an update-loop: There is a Version 1.8.0 from sep 4 2020, and a version 1.7.1 from Jan 3 2021. Whichever version I install -even after uninstalling the ‘older’ version, they keep asking me to update before I can start the app. Result: No Disney+.
I get the impression that the dates and version-numbers are the cause of the loop. Does anyone else have this problem?

I don’t own it but with Android I’d usually start with put in recovery mode and wipe cache.

If that didn’t work then more complex, wipe the data of Google Play Services.

If that didn’t work I’d factory reset and setup again.


Good luck.

I had the exact same problem tonight. Very frustrating. I don’t have a solution but I can say you’re not alone.

Sounds frustrating, can you side load apps on the Anker Nebula?

Anker Apollo user here. I’m not in that update loop you described, but I still cannot use Disney+. At first I would just get stuck in a loading loop at login, and now I’m logged in but it tells me the media is not available anytime I try to watch something. Really frustrating

Does anyone have a solution for this? I’m stuck in the loop also :woman_facepalming:

Anyone tried a factory reset/defaulting the unit and starting over?

1 Like

This doesn’t help at all stop suggesting this

Hey Paul tried that already. I have. No different result from other things I tried. I get the impression it is not a problem with the device, but with the store.

1 Like

Hello Professor, tried that already. That solution doesn’t work. Because it installs the newest version by version-number. But then the device immediately tries to update to the older version with the newer date. And the loop resumes!

That was a spammer I was mentioning, correct it doesn’t work, a spammer doesn’t care though. Spam gone now.