Constant solid red light on eufycam homebase

@AnkerSupport My Homebase was showing a solid red light this morning. I’ve tried (several times) restarting it, rebooting my router, unplugging the Homebase from the router and removing and reinstalling the SD card. Solid red light does not turn white. Please advise!

Are you talking about EUFY cams?

If so you might contact
You will find a possibility for a life chat as well on the web site.


@Springfield what does it say on the app? disconnected?
how is your internet? must be working for other devices, I believe.

I think home base is not connected to internet, not sure what is blocking it. You pretty much did all the trouble shooting.

Have you tried this:
Hold the reset button on home base for few seconds, it will reset it and might work. Be Careful as it might format the SD card and wipe the videos.

Get in touch with


App showed disconnected. Your suggestion worked, thank you!

1 Like

Glad it worked out for you. Continue to enjoy your eufycams :smiley:

Well, it worked for an hour before happening again!

Oh oh something is not going well here, I better leave it to now. Contact them and they should be able to assist you.

Are there any WIFI problems? (disconnections)

1 Like

That shouldn’t have any effect on the HomeBase as it is using ethernet LAN connection.

1 Like

I think I’ve narrowed it down to a problem with my Virgin ‘SuperHub’ 3 router which keeps dropping all devices connected to it by Ethernet cable. Strangely, the WiFi connected devices are all still connected. Got an engineer coming out to hopefully fix it. Never had a router drop Ethernet-connected devices before.

1 Like

So lets say “LAN problems”.
Sometimes I have those situated in the middle of Munich,
which is really no village and TELECOM is the provider.
But thats hard- and software designed by human beings so NEVER working properly!

That is what I supposed.
No WIFI but LAN problems.
( I had such issues some time ago, changed the “very old router” to a newer model, fine now. :grin:
Try it if possible and you have the skills for plug an pray!:joy:

1 Like

Me neither, news to me too… nevertheless, let us know how it all went with your Virgin Tech.

Often here.
Sometimes its getting back by itself, sometimes it needs a reset.
Happend very often with my antique router, now its better.!

1 Like

Ok, so the problem was that one of the Ethernet cables was faulty which was causing the router to drop all of the other Ethernet-connected devices.

1 Like

Fine you solved that problem!
Give the plugs and the sockets from time to time a cleaning as well.
Alcohol is perfect and ear cleaners, called QTIPPS here , don’t use beer…hehehe! :joy:

I am also having a problem with the red light.
Initial setup of my first camera went well, I was very pleased. Then I tried to setup my 2nd camera and it could not be discovered.
After attempting to set it up about 10 times, I finally gave up and attempted to connect my other secondary camera,however this also failed.
Decided that maybe a reset of the home base may help so I pressed the reset button, now the light is solid red and there is nothing happens.
Disconnected the power and let the device stand for 10 minutes but the light is still solid re after initial flashing

This is on a eufycam 2c

I have 2 x Homebase 2 and one works and the other is always red. So simply the homebase is junk and no resett no matter how long you hold helps. Thats why maybie you have hardware problem.