Charge indicators issue

Recently purchased a new ANKER PowerCore 20100, it came with about 50% charge (two blue diodes on).
So I have plugged it in to Anker 4 ports wall charger and charging has stopped on 75% (three blue diodes on) and no other indication of activity. Tried to plug it to my laptop fast charge USB port, but results is the same.

I’m wandering if it’s faulty 4th diode or I’m doing something wrong?

How long did you leave it on charge with Anker 4 port charger? If it’s a single input charge cable then it’ll likely take many hours to fully charge…

According to Anker the PowerCore should take around 11-12 hrs to fully charge on a 2A input, with the lights flashing per ‘diode’ as charge percentage increases.

How long have you been charging the PowerCore and do you get any flashing on the 4th diode, at all?

I just purchased one but I got the power combo that came the case and 4port charger. I actually didn’t charge it right away as mine came charged with 2 dots. I ended up just using the juice that it came with before it plugged it in to recharge to release the charge that it came with and then plugged it in to recharge. I actually just charge it for the first time yesterday at 6:40pm and woke up at 6:00am and check it and it looks good to go with 4 dots when I press the button to check. Maybe trouble shoot the battery pack. Run through all its energy then try charging to see if that works. If not contact anker support to express your concerns

1 Like

Thanks guys for your feedback.

Since it arrived yesterday, I have plugged it to wall charger until end of the day and took it home. Today I plugged it back to wall charger but it stays at 3 bars with no indication of activity. So in total it was about 10 hours.
At some point light went off and it went in to stand by mode.

I presume when battery is about 75% full it suppose to activate forth diode which suppose to blink, am I correct?

1 Like

That’s correct: the 4th LED should be blinking when the battery is charging from 75% to 100%. The lights would all go out when it is done charging. It’s possible the 4th LED is not working. Please contact with a description of this issue and your order number and they’ll be happy to begin the warranty process for you. Thanks!

Yea I would probably contact support. Mine charged overnight and when I woke up this morning I had no more blinking lights which told me that it’s charged completely… good luck but anker customer support is great so you should have it resolved pretty quickly from my experience with them

1 Like


Have same problem, 20h to charge mine, and just 1 led up. I charge it with an Anker Charger 6 port with quick charge 3. When I charge my phone with the battery, sometimes the battery recover all led. Very strange ! Any idea ?

1 Like

Possibly a faulty cable.

Problem solved,
Use genuine cable came along with the pack. Then it will start to blinking the 4th one.

1 Like