Capsule. Cannot browse external hard drive greater than 2TB ?!

Hi All,

The capsule is able to browse files from 2TB externa hard drive / NTFS format.

But it CANNOT read 3TB, 4TB .

No need to mention that I should format FAT32. it does not support file greater 4GB and Windows wont allow to format as well.

Any ideas?

Would suggest you to contact Nebula Support they should help you. What is the hardware storage you are using? What format for storage? Provide these over email.

I have Nebula Capsule and Astro but have not tried connecting such large storage directly…

Not deviating from your question… But are you planning to watch videos, movies, TV-show files?

Just a suggestion, why not plan a media server… Comes very handy.

@hattia On second thought… Can you create multiple partition of 2TB… I have just tested multiple partitions, and this shows up.

It may not be issue with Capsule but the underlying OS… Android 7.1 which may be the issue, and based on it… I dont think Nebula Support can provide a better response than what I mentioned – multiple partitions of 2TB each.

Best of luck!!


This what I would do!

1 Like


Yes partition the drive and make each FAT32.

Alternatively just have multiple smaller storage devices.

What I have is a SD to USB storage dongle and over the years owned different sized SD and microSD cards and collectively is a lot of storage, so I don’t need to partition. This method works out lowest cost over time as your newest purchases don’t have to be higher cost of larger storage as you can use SD cards and move from older to newer devices and older smaller SD can be used for backups like backup infrequently and store in a separate place to cover for fires.

1 Like

Hi All,

Thanks for your reply. The issue has been fixed.

Here was the issue: I tried to connect an external hard drive (NTFS) greater than 2TB to Nebula Capsule. The file manager was not able to display it.

my 3TB external hard drive contains mainly videos files (mp4, mkv, avi…). FAT32 does not work because it is limited (4gb max file size) and windows does not format (the option FAT32 does not show from the format dialog box and trying to format your drive from command dos will fail).

I contacted Nebula support. They confirmed with the statement “First of all, please note our Nebula Capsule supports up to 2TB external hard drive and it is unable to connect to an external hard drive greater than 2TB.”

But Shenoy in this thread was right by trying to partition it. So I used the windows 10 / Disk Management/ Shrink volume feature. On my 3TB (NTFS), I create one partition 2TB and another 1 TB. I connected the 3TB to Nebula and voila ! the 2 partition were display and I was able to browse the content.

Thanks to Shenoy for the suggestion!

Hopefully this thread will help others. I could not find a similar topic on this forum.



@hattia Awesome!! Glad this thread resolved the issue.

Thanks for posting the update :+1:


@hattia if you felt this thread was helpful in anyway, do mark it as “resovled” , which makes it useful / helpful for other members :slight_smile:

Good feedback, we’ll try to remember it for next time.

I’m puzzled why you’d attempt to play >4GB files anyway on a low resolution projector anyway.

@Shenoy the Nebula Master!

1 Like