Cant run Eufy Security app- help?

I recently got a Eufy video doorbell and am not able to open the Eufy Security app on my Android tablet. After installation every time I start the app it states that EufySecurity app has stopped. This occurs prior to the app loading. The tablet I’m running is a Samsung Ativ 700t with Android 8.1.0. Please let me know any suggestions or if there is additional information I can supply.
To date I have tried;
Uninstall/reinstall
Restarts
Download from Anker apk file

Thank you!

@Ciollihome at this point the only other thing I can thank of is to get ahold of support@eufylife they will get it sorted out for you. I have had to get ahold of them a few times and went away having my issues fixed… I ope this helps… :v:

Hey @Ciollihome!

For the eufy security app, please make sure the app has been download from Google play store for your device.

In order to further assist you in this case, please contact us at support@eufylife.com, we will have our engineering team assist you with this case.

Thanks guys. The app was downloaded from the Play Store and I also tried the standalone apk. I’ve sent the log info to support and hopefully they can figure it out!

Try using an older apk

Do you have a link to one? I could only find the most recent.

Here you go

There are plenty you can try, best of luck :+1:

Thanks a bunch!
Unfortunately, I tried all releases from 1.3.0 with the same results. Looks like I’ll be waiting for Anker Support to respond to the email inquiry.

Hey, any updates? I’m trying to get set up on a tablet, too, with no luck.