Can't get the EufyLife Smart Scale App to work

I’ve update my Android EufyLife Smart Scale App to v2.0.1.

  1. The SmartScale home page shows “Disconnected”. My Bluetooth is active and the device is paired. But I have no idea how to get the App to begin the connection process, or even if the App is trying.

  2. Once, the App connected OK, and showed “Connected”, but then I had no idea whether it had received data from the scales; the old version of the App showed the date of the most recent read. I had to go the App Details section, and look at the Trends, to see if the data had been read, and then return to the home page if it had not.

It would be useful if the app:

  1. How an option to “Reconnect”
  2. When it begins to connect, that it displays “Connecting”
  3. When data has been read from the scale, it shows the date and time.
1 Like

I would contact Eufy Support. They’ve helped me in the past with pairing with WiFi issues and did a great job. They may not respond until Monday.

As to the app itself, have you followed the connection process? There is a process on the app that will connect and pair the scale to your phone/app.

I have the scale. Tell me what you tried and what steps you tried. I will see if I can help you get connected.

1 Like

The app will automatically connect to the scale once you step on it. Info can. will be saved to the app Gabby

Thanks for the suggestions. My scale is already paired. What I can’t figure out is the following.

  1. When the SmartScale home page shows “Disconnected”, I have no idea whether the software is trying to connect. It should display feedback such as showing “Connecting…” (or it should flash the display). This may be automatic, but I can’t tell whether it is.
  2. When the SmartScale home page shows “Connected”, I have no idea whether it is reading data, and if it has, I have no idea when it has completed. The old version of the App used to show the date/time. Now today’s home page is indistinguishable from yesterday’s home page. The only way to confirm that the ready has been read, is to select details and scroll down to the daily chart.
  1. It connects when the scale is turned on
  2. It transmits data only when it is on and the phone is within range

This latest app update sucks, they know it does and hopefully they fix it or revert back to the old style

I have the Eufy Smart Scale C1. I also have other Bluetooth devices. Sometimes the apps hiccup and the first thing to do is to uninstall and reinstall the app. This usually sorts it all out.

Once you have done that, just open the EufyLife app and then step on the scale. The rest happens automatically. I will admit that the first few times that I weighed myself, I was expecting something to jump out at me more, but this minimalist approach is working well.

I hope that this helps!