Can't get Eufy Floodlight Camera working with Amazon Alexa

I just purchased a Eufy Floodlight Camera and everything is working as advertised except integration with Amazon Alexa. I have linked the Eufy account and discovered the devices (camera & lights) but Alexa reports the devices as unresponsive. Eufy support are telling me that my case if very unusual but I see similar reports from other users on Amazon. It would really help from any people out there who have this working or have the same problem as me. Eufy are unlikely to fix a problem that they don’t believe exists.


I have the same problem. Echo show 8 says the camera isn’t responding. Camera works fine through the app. I have tried disabling and re-enabling the Alexa skill with no change.

1 Like

I have the same issue with the Floodlights. I did read that you need to go into the Alexa app and change the name for the Camera and Lights as they are discovered with the same names. I will save you sometime as I did change the names, but no luck getting the floodlight camera to work with Alexa. Maybe if more of us state the issue, Eufy will take notice.

Have you tried this?

Yes, the skill is enabled and it detects the lights and the camera. I am just unable to control either from Alexa, it just says the camera is not responding. I am also not able to get the camera’s even detected in Google Home, it detects the lights no problem, but no cameras. I have 3 floodlights, and its the same for all of them.

Same problem here. We are fairly technical, and were able to get everything else working. Even Cam E Was initially not detecting motion we had to put it in test mode and it worked so finally turned off the motion detection and then turned it back on to get it to actually finally work. We’ve tried everything with the flood light camera we can think of - resetting, rebooting, making sure the lights and the camera had different names etc. Alexa tries to show the flood light camera but says it is not responsive. Alexa is able to show the other camera. Sounds like a software problem to me. Eufy needs to test out the floodlight using an echo show 8. We purchased our Eufy floodlight from Home Depot during a sale.

Solution that worked for me. I had the same problem with my eufy 2c cameras. They added fine to Alexa but I just couldn’t view them on my echo show 8. I also tried resetting to factory defaults, resetting the eufy cameras e.t.c.

I got them to work by swiping from the right on the echo home screen to get the menu and choosing smart devices. Scrolled to the eufy cam in the scrolling list of recently used items, clicked it and it opened. After that I was able pull up the camera footage on the echo show with voice command and it didn’t say “not responding”. Hope that works for you. Took me forever to figure that one out.!

Edit: I have ring doorbell and wyze cams too which I could view with no problem so I knew it wasn’t my network connection or credentials. Wasted so much time looking through Alexa and Anker forums…

1 Like

Thanks for the tip but unfortunately that didn’t work for me. I wrote into support yesterday and they replied with:

We regret to say that our floodlight camera recently has an issue working with the Echo Show with a version of But it can work with the echo show with the version of In your case, we are wondering if the system version of your Echo show is You may find it via setting>device options. (See attachment) If yes, rest assured that our engineer will resolve this issue within one month, in this case, may I trouble you to wait for some weeks to see how it works? I assure you that we have a team of discipline, and our engineers work day and night to c resolve this issue as soon as possible.

Sorry that didn’t work. I know it was a different situation but seemed similar. Hope you get that resolved soon.

Same problem. Eufy cam works perfectly. Echo Show is Alexa app shows devices (which the light has been changed to a different name) enabled and connected. When you say ‘Alexa, show me front of house’ (the name of the device known to Alexa), Alexa says, ‘Sorry, I didn’t find that device’.

Eufy/Anker support confirmed that the camera doesn’t yet work with Echo Show version of If Alexa is saying ‘Sorry, I didn’t find that device’ that’s a different issue and may be a user setup error. Delete everything and setup again.

BTW I returned this camera to the store for a refund as it didn’t suit my needs, Alexa working or not. It’s fine for a small yard or driveway but I wanted to view a larger area and so went with a more specialized low-light camera with built-in IR illumination.

Just to follow up, it has been fixed for me.

But arming a floodlight resp. changing the security mode is still not possible via Alexa, right?

This worked for me. Tried connecting on my FireTV by issuing a command to the Echo Plus that controls it - got the error about camera not connected WiFi - though it definitely was. Connected using an echo show (as suggested by sonystyle44), then connected to my FireTV fine (albeit with about 4 seconds delay).

(Using the 2K indoor pan and tilt cam)

I have been running into the same issue. I called eufy support to get help, got none respond nor care to walk me through to figure It out where its when wrong to fix the issue. Very disappointing. My wifi bar show full 5 bars great. All my ring floodlight camps work great. I am starting to think that “Eufy app”for floodlight camp 2 pro are not really compatible with Alexa and google as eufy says it. Very disappointing, At this point, I hope that i still have time to return the Eufy floodlight camp 2 pro.