Can't configure Eufy L70 hybrid

Hi, I’ve been using eufy L70 hybrid for the past month just fine. 4 days ago, it went offline and didn’t come back online by itself in a few minutes so I reset the Wifi, reconfigured and it worked fine. Today, the same thing happened, it went offline, I did the same thing but the problem is, now I can’t add L70 on my eufy home app. It’s the same Wifi, nothing has changed, still 2.4 Ghz, same password, it is just 10 minutes between. So I tried to add the device, and every time, I got this a message like “your phone is not connected to internet.” I’ve been trying for the past two hours. I reset it many times, including the hard reset with the pin. Tried from my ipad as well. Finally aftet two hours, at least I could get to “connecting” but failed. So I tried again but now, it can’t even find the device. What should I do? It’s only been a month since I started using it and I’m already having problems. I’d really appreciate any help.

1 Like

Hey, I have the same problem and no solution till now

Guys email Eufy support :+1:

Already done.
Nothing helped, and the Eufy support wrote that the Robovac is defective.
Because the date of the purchase is older than 12 months (~15month) they can’t help.

Strange is, that the Robovac is connected to my Wi-Fi. But the app can’t find it.
For me it sounds more like a software bug (APP or Robvac) than a hardware defective.
It would be interesting if I could connect via ssh to the Robvac to analyze the logs. Otherwise, I only could try to change the hardware modules.

I don’t know the L70!
Is it not possible to start it without that app?
What about a “hard reset” by removing the battery for 2 minutes and insert it again.
Have you tried this?

1 Like

Yes, it is possible to start the L70 without the app.
But without the app, I can’t define areas which should be avoided.
That was the reason why we bought the L70 :slight_smile:

That was a good hint. I removed the battery today.
No success and the same result, the Robovac is connected after 20% to 30% with my Wi-Fi.
But after 100%, the app doesn’t find the Robovac. :frowning:

I am sure you deleted the app and reinstalled it.#

Now, sorry, I am at the end of my rope.

1 Like

Yes, I did.
But I didn’t delete the cache and app data…
After deleting the cache and app data, I reinstalled the app.
And now it works!!!

Thank you very much!

1 Like

Glad it’s working :+1:

This is a perfect start into the weekend for you!