Cannot re-link eufyCam to google home

I recent un-linked my eufyCams from my google home app on iOS. When I went to re-link them, it won’t let me. See screenshots for the messages I am getting.

I have tried deleting the google home app and reinstalling. I have also removed homebase and set it all up from scratch. None of these things have worked.

Does anyone know how to re-link the cams to google home?

Thanks in advance.


I just reset my iOS device to factory settings and started fresh. I installed google home app and it allowed me to link the eufycams.

Surely there has to be a less extreme way of re-linking the cams? Haha

1 Like

Hello! @Matt_Myors Sincerely apologize for all inconvenience caused! This issue is caused by the latest upgrade of smart home in google assistance. Our engineer team is discussing with google now. Since it mainly occurs in IOS system, if you have a smartphone with Android system, you can have a try on linking your devices to it again. We’ll try our best to resolve this issue as soon as possible. Sincerely thank you for your valuable time.

Yes, seems some issue going on with iOS devices and Google Home.
Can anybody confirm Android phones are able to link eufycam and Google Home??

Thank you for that info.

I was able to connect to Google Home, no issues any more.

1 Like