Cannot log into forum on PC

I’m here in the US and can not log into the forum from my PC. I’m gettitng a 404 error.

2 Likes

In case you’re wondering i was already logged in with my phone and this is why I am able to post. Still can’t log in through my PC though.

Usually it boots you off one browser when you try to log in on another browser. I would check and verify your account info and try again on a different browser

Bugs as usual.
When I click on the link community nothing happens.

I get that sometimes too. It’s just a glitch. Other times, they are doing maintenance on the site. Just try later.

I am having the same issue on one of my browsers, but another is working fine… Maybe I’ll try clearing cache. (?)

Thats why we need a dedicated app :point_up_2:

I got this early. I just closed the browser tab and logged back in. It happens sometimes when you are logged in on one device move to another device. _

I encountered the same issue this morning!

2 Likes

same, i have to use an incognito/private browser tab

I also had the same problem

I had the exact same issue, try a different browser. Using Google Chrome and safari both don’t work for me on iOS, but on Windows, only Edge works. Chrome doesn’t work, neither does firefox.

1 Like

Thanks for the tip, Ryan!

1 Like

I also found logging into this URL works as well:
https://www.anker.com/login

then going to https://community.anker.com keeps you logged in.

2 Likes

Using Google Chrome and safari both don’t work for me. I tried brave and worked.