Can’t control Netflix on Capsule ii

Hello, brand new owner here!

I followed steps online to download and install Netflix, and have it up and running. I’m having difficulty navigating with the controller and the Nebula Connect app though… Once I start the video, I cannot pause or select any other options like subtitles, etc. the only functionality that works is pressing left or right, which skips forwards or back. I can’t pause, navigate around, even in mouse mode. (If I skip forward to make the options appear and then click with mouse mode, it does nothing).

I’ve tried uninstalling and reinstalling Netflix, and checking for updates, nothing works.

Any advice?

Hi There,

Thanks for bringing this case to my attention.

In your case, could you please update the firmware of your Capsule II to the latest V9.5.16 through settings>device preferences>about>system update and see if you could control Netflix well via mouse mode on Nebula Connect app?

If the problem remains, please contact our support team at so that we could verify and assist further. Thank you!

Anker Support Team

Hi all,

An update on the above to help anyone who may have the same issue!

Firstly, Anker support has been awesome and responsive, getting back to me with practical answers and progress quickly. Really appreciative there!

So turns out the first problem was that my system was stuck on an old version (.13), but when I pressed update it said it was the current version. They walked me through how to download and do a USB update, which was quick, simple, and effective! This solved about 50% of my problem, and I’m still in discussion with them to get the rest of the way. Here’s where we’re at now!

(The time delay from first post is actually an indicator of my busy schedule, not their response rate. In fact, they even sent an additional message to check on when I hadn’t gotten back to them quickly! Highly appreciated and excellent customer service!)

As to original Netflix issue, it’s about 50% fixed. When I am in video, the only possible functions on my remote are skip forward and skip backward, same as before. However, when I skip backward and the interface pops up, the up, down, and enter buttons become functional. This means I can navigate to the “back button” in the top left corner, or the “pause/play button” in the bottom left corner, and press enter to use that function, which works correctly. However, pressing left and right on the remote still has the function of skip forward and skip backward, so I cannot navigate to any of the other options (subtitles/language being the most important, which is in the top right)

Now, the good news is that since the firmware update made the interface functional, I can use the Nebula Connect app in “mouse mode” to access the other parts such as subtitles! However, The controls are still screwed up so the process I have to do so is as follows.

  1. Skip backwards on nebula remote (to make interface appear.

  2. Navigate down on nebula remote to pause the video.

  3. Continually press up and down on the nebula remote to keep the interface from disappearing. (Pressing left or right will skip forward or back and remove the interface. Idling for a few seconds will remove the interface as well and force me to repeat from step 1 again)

  4. On the nebula connect app, use mouse mode to move the mouse to desired function, for example, subtitles. (All the while pressing up and down on the nebula remote to keep the interface from disappearing)

  5. Press enter on the nebula connect app to select the function, for example, subtitles, and then make the selection as normal on either the remote or app.

So I can now access all functionality, however it requires the use of two devices and complex movements to reach desired outcome. This is a very positive step in the right direction, but I am still working with customer support on how to get this the rest of the way to full functionality. If left and right prompted left and right, rather than skip forward or backward, it seems it would be perfect!

Anyway, this is just an update in case it helps anyone else with the same issue! I’m still working with support via email.

Either way, the Capsule II is an amazing device and I’m so impressed and happy with it! If I can get Netflix working properly, it’ll be 100% satisfaction.

1 Like

Honestly, I’m quite disappointed with the remote + Netflix issue. Snakeeyes, continually pressing up and down on the nebula remote to keep the interface from disappearing? That is not a solution.

I can’t navigate at all through Netflix. Not even with the app remote. In fact, I’ve considered returning my Nebula II because Netflix was one of the main selling points for me.

I really hope there is an update to fix this.


This remote + Netflix issue is quite frustrating.

1 Like

I agree. The experience with the Capsule 2 and Netflix is disappointing and frustrating. Netflix being one of the most used apps for streaming, you’d expect the money spent $600+ on a refined product to work and function at a bare minimum.
It’s a painful process to try to watch anything on Netflix. I’ve also tried chrome casting Netflix from my phone and it simply does not work. So, back to the “try my luck navigating Netflix app” to watch a show. It totally ruins the experience with the capsule and keeps reminding me “why did I spend this money on a product when cheaper products simply work with no issues?!”

Please try make this better for your customers Anker.

New update, NETFLIX APP OPENS. But remote does not work with app at all.
Chromecasting from iPhone does NOT WORK. Screen mirroring from iPhone does NOT WORK.

The only way to get Netflix to work on the Nebula 2 now is chrome cast from chrome browser on computer.


1 Like

Contact support again :+1:

1 Like

Doesn’t work for me either. I can get into Netflix through the Nebula Manager, but the only button that seems to work is the UP button. Not much I can do with that. I’m reaching out to Support. I’ll report back my experience. If I can’t get Netflix to work, I will be returning.

1 Like

Same problem here with the last update Netflix app can’t be controlled and neither can i cast from my mobile

Dear Anker support,

please try to solve the Netflix issue. It really is on of the most important app.

Have you sent support an email?

No I dien’t. I wait for official update of this problem. I hope if more people will ask they will solve it.

You’re assuming therefore this place is where official Nebula support read and announce.

I’m pretty sure that’s an invalid assumption.

Email Nebula and open ticket, that’s usually the best. Then when a fix is found report it here so the community can help the next user. This place is good for self help between peer owners but not really for outstanding issues none here yet know a fix - that’s best done via email.

Thank you. I already emailed them

1 Like

Did they emailed you back?

Wish I saw this post before purchasing this junk. The main reason we got the nebula was for the Netflix. We cannot control Netflix through the remote nor app. Fix this!

Sorry for responding to an old topic, but nobody posted a solution.

What I did was download a mouse toggle for android tv:
use Downloader, search on MATVT (
Set boss key to 4 (long press back button remote to enable mouse mode)
Under apps, special app access, display over other apps, allow MATVT
Under device preferences, accessibility, enable mouse toggle service.

Now in nebula manager, netflix;
Long press back button on remote to enable mouse mode
Short press back button to switch to scrolling
Long press back button to disable mouse mode

Hope it helps someone.

Hello is there solution to this ? its 2022 and i have everything upgraded inside capsule but cant control nothing in netflix app with the remote… PLZ HELP

I just installed Firefox and use browser for Netflix.

I had to sideload it via download APK then copy via stick and install, and Bluetooth paired a keyboard to make entering passwords email address easier.

Works just fine, if anything better than the native app.

I do though mostly use downloaded MP4 from a stick as it’s easier overall than apps and accounts etc.