Brand new Eufy 30c drops a trail of dust on the carpet!

I’ve only had the Eufy RoboVac 30c since yesterday and the first cleaning run went very smoothly - I was impressed. The second time it was cleaning it was at the very end of its cycle when it went into ‘go-slow’ mode and then started to empty the contents of the dust compartment all over the carpet in a long trail before finally returning home to charge.

This is exactly the kind of thing I really didn’t expect. I had emptied the dust compartment before the cleaning run, as well as cleaning the brushes etc. The dust compartment was not even full when I did check it.

Is this a faulty unit or am I doing something wrong? No point in having a device which leaves a trail of mess all over the place!

1 Like

Normally it is not possible the dust container ist emptied by the robot itself.

Have you checked the filter at the top of the dust container as well.
If this is blocked by a lot of dust, it could be a “blow back” of the debris.
This is my first thought.

I cleaned the filter after the first run - but this was only the second time it has ever been used.

Hard to believe that a filter should become so clogged up after so little use.

That was just an idea I had.
Yes the filter should not be normally not clogged after only ONE use.

You should try another cleaning.
Give the robot another chance! :grin:

Apparently this is Johnny Livingstone Robovac :joy:. He did the same thing :joy::joy:

1 Like

This is why I only ever buy dark patterned carpets, just ignore the dust and save money on not buying a Robovac.

Problems solved!


That’s a not so good appearance of Robovac cleaning :scream:

Does the carpet thickness / plush cause issues for Robovac to keep be around for vacuuming, causing the dirt to fall out?

The carpet looks quite normal (short pile), this should not cause any issues.

Possible faulty Robovac then?

Could be, but I really don’t know how the dust can fall out of the dust box.
Its quite a closed system.

@isujosh have you tried contacting Eufy Support at for the Robovac?

It’s possible that the dust collection box was not seated fully…

Could be as well.
BUT diagnosis from far away is not possible in that certain case
If no more information is given. :wink:

Ok, so it did exactly the same thing on the next run. Completed its cleaning run and then went into ‘go slow’ mode. At that point it started distributing dust and debris on the carpet before settling itself back on the charging point.

Do all the RoboVacs go into ‘go-slow’ mode just before they finish cleaning?

There is no way that dust can be leaking out of the container, there simply is no way for it to escape - and I made sure it was properly ‘clicked in’ during the clean. I can only assume that it is the residual dust and dirt above the cleaning brush which gets re-deposited when the suction stops at a low charge.

I’m contacted Eufy Support - so lets see what they say - thanks for all your comments!

Normally when the battery is low, the robot stops cleaning (vacuuming).
Then it returns slowly to the charger without suction.
I have never seen loosing debris when returning to the charger,
as all the debris in not at the brush it is in the container.

Normally I let the robot work in the single room mode (standard suction), so it stops after 1/2 hour. (11S)

that don’t look too good. I will show this to wifey :slight_smile:

Did you get any resolution to this? Recently bought 2 30c Robovacs, 1 for upstairs, 1 for downstairs. Downstairs vac is running like clockwork, upstairs is leaving the same trail as yours did.

You might want to run it, and when it goes into ‘limp home’ mode press ‘stop’ on the vac or controller. Flip it over and look for something caught in the front wheel (since it’s centered), or possibly the carpet brush.

I contacted Eufy Support and after a lot of back and forth over email, and exchange of pictures and videos, they eventually agreed to replace the item. However, during the time it took to speak to Eufy I was extremely careful to clean the Robovac 30c after each run - not just emptying and cleaning the dust container and filter, but also taking out and cleaning the brushes too. I have not had any problems since and the 30c has been run almost every day.

I’m not proud to say this but I think my carpet was dirtier than I though over the first few runs. Once I was cleaning it on an almost daily basis the amount of dust collected was greatly reduced and I have not had the problem again.

I would recommend that anyone getting a Eufy Robovac 30c cleans their carpet several times first with a traditional vacuum cleaner before setting the Robovac to work. Sounds a bit counter intuitive I know but I think this will help to prevent the problem occuring.

If the problem reappears, then I have told Eufy Support that I will ask for a replacement - but for now at least, all seems to be working well.

1 Like

I noticed this today with the 11s on hardwood. Once it powers down to find it’s charging station, sometimes it just stops and doesn’t move. That’s when dust will fall out for some reason. Container isn’t even 1/4 full.