Brand new Anker Soundcore 2 not fully charging, even with Anker Powerport 5 and Anker Powerline Micro USB cable

So here’s a thing. I ordered a brand new Anker Soundcore 2 from Anker via Amazon. When I got it, I opened it, plugged it into an Anker Powerport 5 with an Anker Powerline Microusb cable.The thing has been charging for over 12 hours now and still isn’t showing as ‘charged’. It still shows a steady red light, indicating that it is charging.

I know the Powerport 5 and the Powerline cable work great because they charge my Motorola Nexus 6 fast and reliably.

Any ideas why this thing would STILL be not fully charged after 12+ hours?

Thanks for your time!

1 Like

Try a firmware update and a new cable.

1 Like

I will try that right now, thanks Jesse.

1 Like

Firmware updated quickly, then connected to power with new usb cable. Lets see how this goes.

1 Like

25 hours in… Still not fully charged.

  1. Firmware has been updated.
  2. Used the incuded USB cable that came with the Soundcore 2
  3. Swapped in Anker’s own Powerline series microusb I already owned.
  4. I have tried Anker’s Powerbank 5 charger for the first 16 hours.
  5. Switched to another 5v 2+ amp charger for the last 9 hours.

At this point I am at a loss as to what to do. It doesn’t seem like a battery should take this long to charge since I am used proper cables and chargers that provide the appropriate charge rate for such a device.

Unfortunately sounds like you get a lemon. Contact tell them all the steps you have taken so far and include your order number serial number.


I will do that as soon as I get back home today, thank you Jesse.

1 Like

No problem. Happy to help.

1 Like

Just thought I’d mention, finally got home around 4 pm tonight, so the Soundcore 2 has been charging almost constantly since 8ish Saturday morning, and it’s STILL not charged.

So I send off a full support email to . Now just waiting to see what happens from here. Thanks again Jesse.

no it is not your Speaker, darn I wish I would’ve seen this earlier, it’s an issue I have brought up with @AnkerOfficial, with the original firmware update I did on mine. So when I first got my SC2 it DID turn white when fully charged, then about 6 months back there was a firmware update I installed and ever since then the light never turns white, which IS annoying because it was the easiest way to know the speaker was fully charged, but when I connect my iPhone to it, i can slide over and see it’s Battery % and it does charge to 100% and it does last for over 24hrs. Then there was another firmware update a month or so ago, which I thought would fix it, nope. So @AnkerOfficial can you help on this subject?

Just know it’s not your speaker, it’s fine, there are other ways to check to see if you fully charged, be careful leaving it plugged in and not using it, that could ruin the battery. I hope that helps, even tho I didn’t really offer a soluton…

1 Like

Chris, I had to go dig out an old iPhone 4S from the office to make this work, but now I do have a way to check the battery level. According to my iPhone, the battery charge on the Soundcore 2 has only reached 70 percent, after over 30 hours of charging.

Your Nexus should be able to show Bluetooth :battery: life as well, on my old one it did as does my S9+ now

1 Like

that’s not good…well I can tell you this for sure, even tho I have not and usually do not check it’s battery level, because it lasts forever, I know that before that original firmware update my speaker would go to 100% and the light would turn white, after the update it stays red. I just checked, mine is at 50% and I have not charged it in a while, so, I just plugged it in, i’ll let it go for about a half hour, because as I recall, with the right cable, this thing charges to full FAST. I will update you afterwards but I recommend unplugging it if it is STILL “charging.” If mine does not hit 100, then that would be super odd, a firmware update SHOULD not have an effect on the battery, but then I guess we will have to submit something to Anker support. Have you emailed them yet? They are incredible!

1 Like

Good evening Elmo, I found an app called BatOn for Android and checked, sure enough, it also shows 70 percent battery life. And no matter what I do, the SoundCore 2 does NOT charge above 70 percent for some reason.

So I’m going to unplug it for now and wait to hear back from Support.

Hey Chris, yeah, it’s not charging over 70 percent. Neither Android or Ios show it charging any higher than that and it’s now been… way too long. I have support emails in to Anker, so now I just have to wait to hear back from them. Thanks for your help :slight_smile:

1 Like

Darn, ok bud. Well Anker support will def fix your problem. The SC2 is an amazing speaker, so, other then that issue, if i were you, I would just ask for a replacement, that little things gets LOUD and I love the Aux option. But hey can you mention what I said about my firmware update and mine changing as well, you know like “hey this kid on the forum…” if so thanks, if you already sent then no worries. Sorry I couldn’t help more!

ok that was super weird, or perfect timing, I just pulled mine off the charger, connected it to phone and it says 70% charged, a min later 80%…and 2 mins after that 90%, so it HAS to be your battery, but I still wanna know why the light changed or well, now, doesn’t.

Dear @Mrbumblesbits , we are so sorry to hear the issue with your SoundCore 2 speaker. Regarding the issue you mentioned,please try using a different cable and wall charger to see if that helps. Ideally, the charger should be 5V/2A.

Normally,the flashing red indicator when the battery is low, solid red indicator while charging, it will become steady white after fully charged.

Be assured that Anker always take customer experience as top concern and we really want to help in this case. If the issue still remains, please contact us at """" for further assistance.

Sorry but I have been discussing this with them, since I have had an SC 2 for a while now, the light on mine used to turn white when it was fully charged, I performed a firmware update and it no longer does, the battery charges to full, but the light stays red. So then I performed another firmware update #Anker released in August and still I have them same light issue. Other then that it’s amazing.