Bluetooth Keyboard not registering keystrokes

Hi All. My Anker bluetooth keyboard A7721 connects fine with my Samsung T700 tablet (old but working ok), but keystrokes just don’t register on the tablet. I have fully charged it and made sure it’s set to Android OS. The keyboard works with my Windows laptop.

Any ideas please?

Thanks you


Have you tried rebooting the t700 and also try unpairing, deleting it from the BT profile and repairing the keyboard

Thanks Tank. I have tried rebooting the T700 plus un-paring and re-pairing. I have found it works fine with a number of windows laptops and new samsung phones but not this older T700 samsung tablet. Do you know if the keyboard can connect to a device via a micro usb cable? this would be an option if it works.


@JayKay The micro USB connection is for charging only as far as I’m aware…

Thanks Ndalby. You are right, I tried connecting it to my PC via a number of cables and it does register as a keyboard.


Maybe the issue is the keyboard itself and you got a defective one. If it’s under warranty, you should get it replaced

So after some reading, it seems that the T700 had a few different firmware updates and the latest one rendered the BT keyboards useless and users had to roll back the firmware. There was specific instructions on how to do so, but now I cant find it. So try doing a google search for “T700 not responding to bluetooth keyboard” hopefully it will give you the result to resolve this

1 Like

Perfect, thanks Tank!. Rolling back the firmware may be above my pay grade, but I know someone who can. When I do I will supply an update. Cheers, J.

Hi, as I dont know how you got in that perticular position I can only give you some basic tapes by which your problem may solve.

  1. unpair the device and then pair again
  2. try rebooting your system
  3. check if your keyboard is fine

Have a nice day!

1 Like

Thanks for your first post here! Welcome to join the community.:hugs: