Another person with a dead HomeBase2 ?

I purchased a whole eufy setup and I’m wondering if I should take it back? My homebase 2 won’t connect no matter what I’ve tried. Most of the time the LED flashes blue on and off. Once it started flashing red and blue, but i have no idea what that meant, so I unplugged it (eufy REALLY needs better documentation). Official support seems non-existent. I was on hold in chat for almost an hour at #1 before I disconnected. What I’ve done so far:

  • Reset it 3 times (by pushing the reset button with a pin until the LED turned red and the voice announced the eufy security was resetting)
  • Unplug it for several hours, plug back in
  • Reset router, as well as change types of wifi connection
  • changed out ethernet cable (it announced it was disconnected from the internet when I did this, so I’m guessing the cable is working)
  • Held sync button down until it flashed red
  • Manually typed in number on bottom of homebase 2 (instead of using the QR scan)
  • Left it plugged in overnight

Sadly, none of these have been successful. I’m hoping there’s someone else out there like me, who has a suggestion or something else to try?

I’m planning on calling support today, some people have suggested to me my homebase might be DOA. I’m wondering if the red and blue flashing light meant something. Hopefully support will be able to help, and I’ll keep updating this page in case anyone has similar issues.

So, it’s all fixed! I noticed there was an updated app on the app store today, so I downloaded that and tried the process one more time. Somehow the updated app worked! It’s weird that the app that was on the app store YESTERDAY didn’t work, but today’s does… anyway i synced one camera as a test and it worked wonderfully. This weekend I plan on tackling installing the 3 cams and the doorbell. Wish me luck!

1 Like

Glad to hear the problem has been solved. Always make sure to check if there is an update for and app. It is usually the cause for problems like these.

Glad it worked finally for you. I wonder if something in the new update caused the issue in the old one to not to work. Maybe they need to push a notify to update the app

Good luck :+1: