Anker USB 3.0 Docking Station

I’m using an Anker USB 3.0 Docking Station for attaching 2 monitors and sound to my laptop. Laptop is Dell Precision M6800 running Windows 10, 64-bit OS. This has worked fine for a couple of years, when suddenly my laptop gives me message that it doesn’t recognize the USB cable that connects laptop to docking station, I have other items plugged into USB ports on laptop that are working just fine, so I assumed the cable was bad so I purchased a new one, but getting same error message. I’ve tried plugging into every USB port on my laptop (2.o and 3.0) but get same results.
The docking station power light comes on when I plug it into electrical and no other errors are showing up anywhere. Problem: Is there anything else to test before I toss it into the trash? I can’t find any way to test it further. Thanks in advance for any ideas you might present.

1 Like


First, thanks very much for the detailed information on what you are running and have connected. Great help.

I have had similar issues with some apple products, and I have a couple of things maybe for you t try:

  • check the input port on the docking station from the laptop. Possibly it could be dirty and need a little cleaning, how often are you plugging and unplugging the charger? Could be that if dirty the contacts are obstructed and not all of the info / power is getting to the docking station.
  • saw that you changed the cable, so :+1:
  • also doesn’t sound like a laptop port issue

Do you have another device that you could test with?

Also wondering if a windows update caused the docking station to not be recognized, if you are able to go into the control panel and check for the docking station, perhaps a fresh reinstall of it and try again?

Don’t throw it in the rubish bin yet, as there a lot of helpful members that may have some other ideas to try.

Good luck :wink:

1 Like

So I’d say you’re looking bad as you have done nearly all I would have done already.

Things you not yet tried (or you did but didn’t mention)

  • Power off your the laptop fully (shut down).
  • Leave if off
  • unplug the battery
  • have a cup of coffee / walk / beer / sleep (wait > 15 minutes)
  • plug in battery and power
  • turn on.

This might clear a hardware error which got flagged up by the hardware which is manifesting as software error higher up.

If that doesn’t work…

Try disabling and enabling in Windows Settings device manager.

If that doesn’t work…

Try removing the hardware then scan for new hardware.

If that doesn’t work… is this out of warranty so you cannot process a warranty claim? If out of warranty just before the docking station goes into the bin …

Give it a bit of a firm whack. Loosen potentially dirt which got into it. If dirt didn’t then a bit of moisture may have rusted / shorted it and a whack might give it a bit more life.


Hope you can get it working

1 Like

Kindly let us know how goes the battle, hopefully you’re able to return the docking station to service :slight_smile: