Anker USB 3.0 Docking Station Audio Not Working: Suggestions?

I have been having issues with my Anker USB 3.0 Docking Station, specifically that the audio does not work. The laptop’s audio works fine when not hooked up to the docking station. I have the laptop hooked up to two external monitors via the docking station, and I operate with the laptop screen disconnected. I have tried audio through the headphones jack and by using a USB headset. Neither have worked. I called Anker, and they said it was a product defect and sent me a new product. The replacement has the same issue.

I was wondering if anyone had any suggestions on fixes or has experienced this same problem.

If the replacement has the same issue I would say the fault is most likely on your laptop, most likely a driver or setting issue. What type of laptop and operating system are you running?

I thought the same but it isn’t really helpful to go look in all directions.

A forum for that make model of laptop may help.

I also have instinct that the laptop has an official docking station which assumes audio is sent to the docking station. IT might be fixable in device driver settings.

It is a Dell Inspiron two-in one laptop: I want to say 13 7000 Series. Operating system is Windows 10.

I recommend you go into a forum of your laptop and ask there. There are so many possible causes.

Aside: good of Anker to replace!

As @nigelhealy has mentioned, you would also benefit from raising the issue on the Dell / Microsoft forums aswell, as the issue could be related to either a Windows 10 setting or propriety Dell software (for their own docks).

To get you started though you could try re-installing the driver for the dock and making sure your running the latest version of DisplayLink.


Thanks everyone for the help. I finally managed to troubleshoot this. Turns out RealTek Audio for Windows 10 was having issues. I uninstalled and reinstalled the RealTek Audio driver: (this site had good directions and link to RealTek). Then I disabled the USB Audio speakers that my computer was trying to run off of so that it was running of off the speaker.

Finally resolved this.


Glad to hear your up and running again :thumbsup: