ANKER Ultra-Compact Bluetooth Keyboard AK7726

This is a strange development, which seems to have arisen out of the last one or two iPADIOS updates.
I have an iPad Air 2.
I use different keyboards (English, French, Spanish, Russian). The Russian keyboard now has a strange issue:

  • I’m typing in English
  • I type for a little while in English
  • I then want to switch to Russian
  • я говорю по-русски
  • I then switch back to English
  • When I press the “Caps Lock” key, it will switch me back to Russian, even though I did not ask for the Russian keyboard, and all characters will be in lower case lowercase in Russian
    -созыва дослушав (the keys I pressed were caps lock, with space between the 2 words and after the 2nd word).
  • So there’s a “Caps Lock” problem involving the Russian keyboard

I have two ANKER AK7726 and they both behave this way. If I switch to Caps Lock mode Ш ушив газ ензштп шт Кгыышфт (I wind up typing in Russian).

1 Like

this is more with the Apple iPadOS than it has to do with Anker keyboard.

What happens when you try to type using the iPad onscreen keyboard?

Try to remove the Anker Keyboard from Bluetooth Setting and pair it again.

Would say, check for updates which may come for iPadOS

Even as I wrote my explanation, I really did think this is an Apple issue, rather than Anker’s. Thanks for your answer. I have found a way to work around it. It’s a pain, but I don’t use the Russian keyboard too often, so it’s less important than I thought. Thanks again!