Anker Soundcore Q20 stops playing

Paired the headphones successfully last year with my phone and no problems. Fast forward to this year, and Bluetooth connection between phone and headphones drops after random amount of time. sometimes restores with no interaction after a minute or so, other times never restores. Fully charged phone and headphones. Tried forgetting BT device connection, but still dropping connection between phone and headphones. Distance between the two are less than 3 feet.

Have you tried resetting the headphones?

Is it the only device you’ve paired with?

The phone is the only device paired with the headphones, although the phone is also paired with my car, and a bluetooth speaker. Those are not in use while using the headphones however.

What is the process for resetting the headphones?

Use search, it’s faster than asking the question.

Finds quickly this

I did search, but actually found differing methods for the reset. YouTube helped in that regard, and I did the factory reset procedure. I thought all was well after that since I was able to mow the lawn (about 90 minutes) and not have the headphones stop playing.

The next time I went to mow, they started doing the same thing again. Powered them off, and back on, and then they played again for maybe 15 minutes. Did another factory reset before the next time, hoping that would at least last through another mowing session. Nope! Maybe 15-20 minutes, and back to the same old thing.

I guess I just have a garbage pair. Maybe a total of 40 hours of usage since I’ve had them.

Based on this it probably is a bad weld cracked inside the headphones and are junk.

There is some chance, less than the above, you have a newly added electromagnetic interference cause in your vicinity. This is typically an old microwave oven.

Or a new Wifi router on 2.4Ghz. As the signal diffracts around a corner it’s frequency alters and overlaps bluetooth.

These are slim topics to explore, but if you go to another location where the local interference doesn’t exist, and the problem remains, it must be a dud unit, but if the problem disappears then it’s a leaking 2.4Ghz source in your area which will likely break a replacement unit’s quality.