Anker Soundcore Q20 not playing music

When I connect through Bluetooth there is only a high pitched noise. If I connect through the wire music plays, I’ve tried to connect with other devices it works fine it just won’t play music. The controls on the headphones are working, just not music. Any suggestions?

To which device are you pairing Life Q20 – Windows (10) PC / Laptop OR Smartphone?

When Life Q20 is paired to Laptop, it pairs as Headset and Headphones.

For only listening music, use the Headphones mode on Laptop. Headset mode gives bad quality audio because it is meant for calls and uses both speaker & mic on Life Q20.

If you are pairing to Smartphone - this shouldn’t matter and you should hear clear audio

Do confirm the device you use.



May be try a reset of Soundcore Life Q20. Try the below

  1. Remove / forget the Bluetooth pairing for Life Q20 completely on your Smartphone
  2. Plug into the power supply.
  3. Hold the Power and Volume+ buttons for 5 seconds. You will see a purple light flash twice.
  4. Pair the Life Q20 back to your Smartphone.

Let us know if this works.

Also, might be worth to try listening to audio, by disabling the Noise Cancellation. Just to make sure, Hold the NC button for 1 second to turn it on. A green light will illuminate. Now Hold the NC button again until it turns off - we want it to be turned OFF. Now try listening to the audio, if it works well.

Either ways, do reach out to Soundcore Support

Additionally, you may also post this on Soundcore Collective community


Yeah tried all of that today none seemed to work, it’s bizzare because it worked fine yesterday but they aren’t even making the noise they make when they turn on anymore, tha ks for the help though, appreciate it.

Since you have tried all these, would suggest you reach to Soundcore Support , hopefully you should hear the resolution steps

1 Like

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  • Make sure your headphones are fully charged.
  • Try these headphones on another Bluetooth device to see if the problem persists.
  • “Forget” the headphones in your device’s Bluetooth history and reset the headphones by holding the Play and Volume+ buttons for 5 seconds while the headphones are charging, then pair them again to test.

If the issue still persists, don’t worry, please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.

Thanks a lot. This did it for me