Anker Soundcore Mini Issue (just a stable greyish-blue light)

I have bought Anker Soundcore Mini a couple of days ago. I put the speaker on charge for around 3 hours and plugged it out when the white LED turned off. However, the speaker is not turning on despite trying. a greyish-blue LED turns on (constant and not blinking) when the power is switched on. I have tried a couple of things after researching on Internet:

pressing the Mode button to change mode

pressing the Mode button for 4-5 seconds

I repeated the same when plugged in (via charger) as well but nothing happens. There is no bluetooth signal, no radio, no music via aux and SD card. Its just dead since I unboxed. Can you please help?

@syedarsal As the unit is not powering off, it’s unlikely to be a charge related issue. You have also covered a reset by pressing the mode button for 3 seconds or more so it sounds like a defective unit you have received.

I would suggest you reach out to for assistance and replacement under your warranty.

As you’re new you may also want to consider joining the official Soundcore community at

thanks for prompt response @ndalby. But i think i did not explain the issue correctly. the issue is not related to ‘not powering off’. the issue is when it is charged, i switch on the device, consequently the LED under the volume button turns on but thats it. nothing ever happens after that. i searched for bluetooh signals via mobile phone but there were not. i tried changing mode to radio but all in vain. yes i have mailed to soundcore team and i’ll join the soundcore community too.

Glad to hear you’ve reached out to the support, as it’s approaching the weekend it may take a day or so longer than usual for a response but they will address your issue.

I only mentioned charging as sometimes, a low charge can cause issues and I was just ruling that one out :slightly_smiling_face:

yes i am expecting a delay that is why i am posting this thread, hoping to get a quick response (call me impatient lol). i might try charging with the original power cable. it’s still in the box.

if someone has issue understanding the what exactly issue i an facing, please refer to this video.
ps. this is not my video. i just happened to come across this while googling similar issues