Anker Soundcore Life P2 - microphone issue on laptop only

Hey guys!

My Soundcore Life P2 earbuds arrived yesterday and I was really excited to use them for video calls as I’d seen some YouTube reviews and the microphone seemed good enough.

I tested the microphone on my iPhone first, and no complaints there, but when I connected it to my Macbook the microphone just sounds really muffled and far away. Do you know if the microphone is supposed to work only with a phone?

If not, are there any settings I’m missing here? I didn’t change any settings when I connected it to my laptop but I made sure the input was set to the earbuds.


Update: whenever I have these connected to my laptop and I try to increase the input volume, the earbuds output quality deteriorates a lot and changes the volume balance to the left earbud only, I have no idea why

I suppose you run WIN on your laptop:
Remove the default driver (given by MS) and
install the driver from the manufacturer of you bt-card instead.
This often helps.

Hey @Chiquinho, I have MacOS, I’m not sure I have that option to be honest

Don’t have Mac, I run Linux but buds have two modes, headset and headphones. In headset mode the audio is awful. See if your buds have effectively two sound devices, if so try the other.

1 Like

Tried that, managed to switch between the two but the mic still sucks haha I’ll check in with Apple directly and use the computer mic when making video calls (whilst using the earbuds for speakers) @professor

Thank you for your suggestions! :slight_smile:

1 Like