Anker Soundcore liberty air 2 4.20 - Wireless charging problem


A few days ago I purchased 2 pairs of Anker Soundcore liberty air 2.

The first thing I did after the unboxing was to update them to the latest firmware 4.20. The update was made successfully.
The wireless charging future doesn’t work with any of the pairs. I already tried with multiple wireless qi chargers.

Are you guys experiencing the same problem?
Is this a software-related issue and will be fixed? If so, anyone knows how soon?
Is a hardware issue with both pairs of headphones and I should return them?

Thank you,

If you have tried multiple times and they made sure the wireless chargers are not the issue, then yea, you should contact support and get them exchanged

Also make sure they are the Pro edition by connecting them to the app. I got burned and they sent me the regular ones, not Anker, 3rd party seller. Long story but yea I posted about it. Check.

Yes, they show as Liberty Air 2 in the app. I have two pairs, I bought them at the same time ,one black and one white, what makes it interesting is that both pair have the problem. I’m not sure if I should change them at the 3rd party seller or directly at anker.
What is the return process at anker? I should first send my headphones and then I receive another pair?

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following information:

Please let us know what Wireless charger you are using. Please also make sure put the earphone into the charging case and close the charging case cover. Put the case on the wireless charging pad and make sure they are center aligned. When the LED light breath in white, it indicates it’s being charging steadily.

If the issue still persists, don’t worry, please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.

I was having the same problem. I could actually get it to work… but maybe only once every 20 times I put it down dead center. The pad would even light up to show that it registered something chargable was on it, but the lights on the pod would not react.

I have an Anker 10W wireless charging pad and my S20+ was working perfectly fine with it, charging the second I put it down, so I was pretty sure that wasn’t it.

What I eventually realized is, the charging zone for the case (and probably pad) must be TINY as heck.

I trial and error’d the positioning until I figured out that putting the pod down dead center was NOT what worked. I actually needed to place if slightly off center, with the charging lights EXACTLY aligned with the “Anker” logo on my pad.

With that PRECISE alignment, I could get it to charge every time. Not even half an inch to either side of the “Anker” on the pad though, and I would get the same non-response as before.

To be honest it might just be easier and quicker to just plug it in (Or maybe get one of those non-anker brand charging pads that has multiple coils).