Anker Soundcore 2 connected to bluetooth but doesn't show up in output sound MacOS

With the recent update to MacOS Mojave, I have trouble connecting. I’ll turn it on and it connects to my Macbook Pro. I’ll see it in my bluetooth devices, but no sound comes out. I check the sound preference window, and it doesn’t show up as an available output. I have to disconnect and then connect to have it finally work.

So my routine is to turn it on, after it automatically connects, I go into my bluetooth preferences, manually disconnect, then connect, and it will work. I’ve tried un pairing and re-pairing every which way.

Is there anything else I can try to have it connect without going through those extra steps? I haven’t had a problem til the update.


I have seen exactly same behavior with my Liberty Air earphones. It connects and disconnects, then I have to manually hit connect. After that it works fine but the initial hiccup is annoying.
It was fine in High Sierrra (would always automatically connect). In Mojave this problem is there…
One more thing I see is that all other bluetooth earphones/headphones that I have still connect automatically in Mojave (just the Liberty air has issues).
On further investigation, I found that liberty air is the only one that uses a bluetooth SPP connection mode for connection. So I suspect that it may be the issue. Rest of the bunch do not use serial connection.
I suggest you check the connection mode by going into your system information (press option key and click apple icon in top left and choose the first option). Then check the bluetooth section and see the device (Soundcore 2). It will give all the information.

I don’t know what SSP support is but, it says “yes” in under Soundcore. I also have a Jabra bluetooth headphone that I seldomnly use, but connects without a problem. That is also SSP supported.

Hopefully someone can give us a solution.

Have you tried resetting the BT module under the BT menu Debug option?

Just tried it, didn’t do anything.