Anker Soundcore 2 cannot update firmware ( Not reading USB )


I have recently purchased a refurbished Anker Soundcore 2 from Amazon, it is certified by official providers such as Anker or Amazon to work properly.
I test it, everything is working properly. My following move was to update its firmware.
-I get the installer and the driver,
-run setup,
-restart, run .exe,
I connect the speaker through usb, the updating software doesn’t read it even though the led was showing that it is charging while connected via usb.

Is there any fix for the software or is it because of the usb?

EDIT: The windows device manager doesn’t show any speaker device or anything when connecting


Are you also following the steps in the update manual, step 3 parts A thru D?

1 Like

I’m having the same issue… The firmware update tool doesn’t recognize the Soundcore 2.
I’ve tried all the steps from part 3, but the Soundcore 2 will not connect with either the “Hold Bluetooth Button” method or “Hold Volume- and Play Buttons” method. The speaker just freezes, then I have to hold power for 10s to get it to reset.
Any ideas?

1 Like

Managed to get the Soundcore 2 connected using a different USB port and the “hold Bluetooth” button method, but when I try to update using the firmware downloaded from here, I’m getting this error.

1 Like

It appears you may have a bad component. Is it under warranty?

I was able to update my soundcore 2 and motion q no problem on my Windows 10 laptop but received the same error when I tried to update my Boost. I re-downloaded the boost firmware and followed the YouTube video and was able to update the firmware. Not sure if the firmware was corrupted during download or if I missed a step but the video is the most accurate instruction monkey see monkey do​:monkey::sunglasses:


I followed the instructions listed here:

Specifically C2 has now bricked my SoundCore2. No lights. Can’t turn it on. Nothing.

Hi @Craig_Dennis , sorry to hear about that. When you say the SoundCore is bricked, did it attempt to or complete the firmware update prior to being ‘bricked’ or do you just not have any response after using the button combination? Do you get any response if you long press the play/pause or volume up/down keys (which should reset the SoundCore)?

If the above key combinations do not work I suggest you reach out to with your issue, including serial and troubleshooting steps taken after the attempt to update the firmware. They should be able to get you sorted out.

No, it never connected via USB despite many different attempts. So no firmware update was started.
I’ve tried every button combination again, for varying lengths of time. Nothing.
No lights, sounds, or connection via USB. And now it won’t turn on.

I have reached out to Anker support and I’m awaiting a response.


I was having the same problem. I tired redownloading the Firmware with Microsoft edge rather than Chrome. Low and behold I was able to successfully flash firmware to the Sound Core 2 Speaker.


I have the same problem. Does it solved for you? Please let me know if it’s solved

I have the same problem. Does it solved for you now?

If can’t connect with the Bluetooth button, then use the workaround C2 (Volume"-" and Play buttons) to connect the device in firmware upgrade mode.
If you receive the error in question while upgrading the firmware, try on another USB port,browser or even another PC.
If device is not responsive after firmware upgrade attempt push and hold Power button for at least 10 seconds to exit firmware upgrade mode and start over.

i have a soundcore select, and need original firmware, somebody help me?

1 Like