Anker Soundbuds Curve won't power on

Hey guys,

Have had these soundbuds curve for approximately 2 months now and they no longer power on. I can charge them to maximum battery - as indicated by the blue light - but once I disconnect it from the USB source, they won’t power on.

I’ve read some suggestions for other Anker bluetooth earphones, to try turning them on whilst they’re plugged in. When I do this, the light turns off and nothing happens. I’ve tried different USB cables, plugging them into my PC and power adapter as well.

Is there some sort of button sequence to reset the earphones themselves?

Any help/solutions is much appreciated.


Just contact anker customer service and they should help you. Since you have 18 month warranty shouldn’t be a problem getting them replaced, that being of course you purchased them from an authorized dealer.

Is the right address to contact? Haven’t received a response yet have read that others were getting almost instantaneous replies. Have had to resort to wired buds for the gym and already miss the wireless function.

I purchased them from AnkerDirect on Amazon.

@phuzun is correct. :sunglasses:

1 Like

Thanks @namroc22 and @pauldey for your help!

Yes, @phuzun please contact for a warranty replacement. Please include your Amazon order number to help expedite the process. Thank you!


@namroc22 @phuzun @TechnicallyWell Thanks a lot for your quick response, much appreciate it. @phuzun Let’s try some troubleshooting here:

  1. Try another 5V wall charger and cable to charge the earbuds at least 24 hours no matter the indicator is on or off.
  2. Make sure the charger and cable are working before you charge the earbuds.

If this issue persists, could you please contact with your serial number and order number? We will cover an 18-month warranty regarding any quality issue related. Thanks.


email anker

good to know

I guess they won’t go into pairing mode either if you continue to hold down the power?

Yup I’m looking at my second RMA on my set of Soundbuds Curve for this very issue. The first set were DOA, and this set degraded over the first few weeks of use. Have tried all of the suggested remedies (power sources, cables, extra long charge etc). I’m beginning to think there is just something completely borked in the power up circuit for this design :frowning:

I have the same problem with my earphones. I contacted the customer care and they notified me that they will not send a replacement to me. Please help.