Anker PowerPort PD+ 2 (Model A2626JD1-1) Won't Charge Samsung A71 Phone via PD (USB C) Port

I recently purchased an Anker PowerPort PD+ 2 (Model A2626JD1-1) to charge my Samsung Galaxy A71 phone with, since I was looking for a fast charger using a USB C to C cable for it. However, when I connected my phone to this device (Using a nice braided Anker USB C to C cable that works fine with my Anker car charger) into the PD port, I get no reaction at all on my phone, like nothing had been plugged in. The USB A port works fine, but that wasn’t why I purchased this, I was wanting to use the faster USB C port to charge with. Is the charger broke or is the “PD” port not supposed to be able to charge a device like my phone {IE: working as intended)

It seems like the USB-C PD port is malfunctioning.
If you have another USB-C device, you can test it with that.

Thanks, I tried it with a co-worker’s phone and had the same result, so it looks like I purchased a dud. I have my receipt with me so when I get off work tonight I’ll take it back for a refund (it was the last one they had on the shelf)

Thanks again

Ok, just to update, I went by the store (Walmart) and they did have another unit, so before I did an exchange, requested I take it out of the package and make sure it worked (charge my Samsung Android phone via direct connection from the PD port to my phone with a USB-C to C cable and, just like the last unit, it had no effect, like it may as well not be plugged into anything.

I’ve verified the cable works fine via my Anker car charger with USB-C port, and both units worked fine (charged my phone) using a USB-A to C cable.

I’m left to assume that either there was an unlikely event of multiple units having the same malfunction, new out-of-the-box, or the standard PD port on that unit (PowerPort PD+ 2 (Model A2626JD1-1) simply isn’t compatible for my use (a single unit with a fast charging USB-C port I can connect my Samsung Android phone to directly with a USB-C to C cable for charging, while also having the USB-A port with PowerIQ 2.0 (I liked that feature and it seemed to charge my other devices nicely) for other devices.

Does anyone know of an alternative model that meets those requirements?

Samsung uses often voltages which are not PD older protocols, require newer PD like PD PDO PPS.

Photo the supplied charger which came with the phone. PD 2 is 5V 9V 15V 20V. The Powerport you mention looks not on Anker site so can’t look it up either, take a photo of that (if you have it), it may be doing 5V 9V only.

So what may be happening is either the phone needs PD 3 PDO PPS and the Anker charger is PD 2 so PDO PPS, or your phone is PD 3 but needs a voltage (E.g. 20V) which the Anker PD 2 doesn’t do.

This should be obvious by simply reading your included charger and searching for Anker chargers with the same voltages and protocols.

PD keeps evolving, Samsung tends to require newer PD 3 versions than older Anker charger supported. If say your phone does need PPS, then Anker does sell them.

I can’t find your phone specs particularly but if you search for Samsung you can see the problem Samsung is causing here

Use of PD version 3 while chances are Anker is PD 2 you’d need a PD 3 Anker changer, may be the answer.

This is the charger in question
The actual box had much more detailed info on output types/voltages/etc but I don’t have that anymore since it was returned

The factory charger had this info:

PD 3.0 25W
Output: 5V-3A / 9V-2.77A
PPS: 3.3-5.9V / 3A 3.3-11V / 2.25A
Charging output: Max 25W

This is the only specifics I could find on my phone’s battery/charging

USB Type-C 2.0, USB On-The-Go
BATTERY Type Li-Po 4500 mAh, non-removable
Charging Fast charging 25W

As I suspected, the Samsung requires from PD for it to be PPS, as written on the charger says PD 3, the Anker charger was not PD 3, it was PD 2. Seek an Anker PD 3 PPS charger.

PD 3 vs PD 2 version, PD 2 is specific voltages, PD 3 is any voltage up to a maximum.

Chances are the reason the Anker non-PD port worked is the Samsung will work with non-PD, just not PD 2 non-PPS. If Samsung wanted to be less awkward, they could always if seeing PD 2 accept say 9V or 15V. I think Samsung want 10V which is not part of PD2.

Truly a weird issueb I’d recommend just getting your money back and getting a different charger