Anker PowerCore Metro Essential 20000 PD Not charging

Hello, I just got a “new” PowerCore Metro Essential 20000 PD on eBay, seller said it was new, but when plugged to charge the first white led blinks for hours, and when unplugged it does not deliver power to the device (USB-C or USB-A), then I read the manual and it does not say anything about first charge but i noticed tho it says something about double clicking the wheel-meter and one led turns green, not sure what that means. Then I read about the “looping” you can perform to the powerbank but nothing changes, here is what I have learned so far:

  1. When plugged just one white led blinks.
  2. When unplugged it does not deliver charge to the device.
  3. When unplugged and double click on the wheel-meter the white led turns green, if you press again it turns off
  4. If I plug something to charge (it does not) and then the double click, no green led, like it is dead.

I’m trying to determinate if I have a defective unit so I can ask for a refund. I use a Belkin 27 W USB-C Home Charger. Did not purchase from Ankerdirect. Any help will be appreciated.

Thanks!

Have you tried another cable, another charger?
The green light indicates “trickle charging”.

I have tried with the Anker provided cable and Belkin MIXIT DuraTek USB-C Cable, and just that one charger. Do you think that is the problem?

I also have a Nintendo Switch charger and Apple’s 29 W MacBook charger at hand.

Try all chargers you can get your hands on.
And be patient, it could take a while to see something changing (charging)
I had the same problem, which was solved after using another charger.

1 Like

OK will keep on with the tests! Thanks!