Anker PowerCore 26800 (Model no.: A1277) no longer charges

My Anker PowerCore 26800 does not charge anymore. According to the descriptions, I can connect 2 adapters of 5 volts with 2 ampere together for a charge of 6 hours.

I did this, however, the PowerCore charged up till 50%, suddenly all the LEDs went off (less than 2 hours of charging time).
If I re-connect 1 adapter to charge the PowerCore (1 x 5 volts and 2 ampere), the first LED will flash briefly, and rapidly every LED went off.

When no cable is attached to the PowerCore, and pressing the button at the side of the PowerCore, no LED on the PowerCore gives an indication of the capacity anymore.

Is there a given solution for this problem? I’ve already contact de seller, because I think the PowerCore is broken.

Model number: A1277

From your description it does sound like something is off. Firstly have you tried charging with different cables and wall chargers, as this can often be the cause of many charging issues (cables). Secondly, you say you have contacted the seller, is this a third party seller or

Hello ndalby,

I’ve tried to charge it with the two USB cables which has came with the Anker PowerCore product. And later I tried it with the original Samsung USB cables, but no effect.

What do you mean by, something is off? When I put the cable in my phone it charges the phone correctly.

The seller is a third party seller.

Any ideas how to solve this?

Kind regards,

Hi @richard33 , I mean it sounds like something is not right with the powercore, with it only charging to 50% and LED’s not giving a feedback. I would still drop an email to with your issue, serial and troubleshooting steps taken. It may also be worth mentioning your third party purchase location…

1 Like