Anker PowerCore 26800 External Battery issue

Hi all,

I lived in Moscow for a while and bought many Anker official products when I was there.

All of them are still working fine, except the PowerCore 26800, which I bought on 29th April 2018.

Within 6 months, the led lights stopped showing me the charge levels, but I just charged it often when using it to make sure I wasn’t caught out.

Now, I charge it for 24+ hours (in both ports) but it doesn’t seem to work at all. Without the led lights working, I also can’t see if it’s actually charging or not.

I’m now based in Spain and would really appreciate some help knowing how to fix this as it wasn’t cheap, at the time.

Thanks in advance for any help…



Have you tried a resetting?
Connect the in- and the output via cable.

Sorry to sound dumb, but how do I do this please? Just connect the in and out ports?

take one cable, USB A to USB Micro B.

Connect one of the USB A sockets (output) to one of the Micro B sockets (input) and press the power button.

This will reset the electronics.

Also try different USB cables, and try a different USB charger.


Thank you. I tried both but it doesn’t seem to help.

Without the LED lights showing the charge, it’s very difficult to know what the problem is.

How long do these packs last, do you know? I’ve had mine for two years and use about once a month, on average. Maybe a bit more, but certainly not a lot.

I’d contact support and see if they can help you out. For me when I have issues with my large cap PowerCore the reset options works.

1 Like