Anker PowerCore+ 20100 USB-C not charging

Hi. I just recently purchased the Anker PowerCore+ 20100 USB-C. Right out of the box, I pressed the button and, sure enough, three leds lit up. But they never turned off. I tried plugging the powerbank into an AC adapter ( the official Anker PowerPort+ 1) and… the leds stayed on but didn’t display the charging sequence (dimming then brigthening) just a solid light. Tried to reset the battery by inserting one end into the USB-A and one into the USB-C but no result. All three ports deliver power, but the battery cannot be charged.
I drained the battery completely and finally the leds turned off. Plugging it into the wall adapter proved to work, the powerbank started to charge but after removing it from the outlet, the leds turned on again and stayed on and I was unable to recharge it until I had completely drained it. Am I doing something wrong?

Try a reset:
Use the cable added and try a “shortcut” by connecting in- and out-put.

Tried that and it didn’t do anything at all…

Then you should contact the support

In order for the reset to work you need to keep it connected for 10 seconds. Then when you go to charge it do NOT press any buttons and just plug it in. If all else fails reach out to

1 Like