Anker Powercore 20100 not charging properly

Recently i have discovered that my charging unit fails at charging anything larger than an iphone.
It doesn’t charge my wife’s iphone 7 and it doesn’t charge my Samsung galaxy tab A.

What will happen is, I’ll connect one port to my charging unit, it’ll charge for a couple of secondsvthen then off.

This is highly frustrating as I brought an Anker product knowing how good they are.

Is there a way to resolve this issue please or some kind of factory reset on the charging unit it self?

Thank you in advance.

Are you sure your batterypack is fully charged? Depending on the output voltage of the power brick you are using it could take anywhere from 8 to 12 hours to fully charge this type of batterypack.

Also, uave you tried using different cables to charge these devices?

One thing you can do is plug the usb cable into the batterypack and take the other end and plug it into the charge port, this forces a internal reset of the batterypack. And then proceed to try and charge it fully and go from there.

Alternatively you can send and Ness age to with your order number and serial number and any steps taken to diagnose the problem and they will help with in warranty exchange/replacement

1 Like

Thank you for your reply,

I have tried the internal reset route only now the second port will only work for about 1min.

I have emailed support

Thank you

It that solution appears to have worked for the second port now.

Is one port for fast charging and one port for standard charging?

Nope, back to square one

Are you sure your batterypack is fully charged? Also have you tried using different cables?