Anker PowerCore 20100 faulty? Switiching off after 15 seconds of charging


Hope someone can help. I’ve bought the device in the title and it arrived fully charged in the box (not sure that’s normal) but anyway when I plug my iPhone in to charge it keeps turning itself off after 10-15 seconds of charging.

There is no blue lights on whilst my device is plugged in either, which on all my other power banks has the blue lights on whilst charging.

Is this normal? I’m worrying now as I’ve left it too late and I’m going away Tuesday and needed this powerbank for the trip :confused: I’ve tried different cables too.


I have the exact same model, are you seeing a full 4 blue lights when you press the side button, but then when you are charging it is showing none illuminated and deliver a charge? If this is the case, I would contact anker customer care at They are super helpful and responsive, but I do not believe you would receive one prior to Tuesday. Was it purchased directly from Anker or Anker’s Amazon?

Thanks for the reply. Yeah 4 blue lights when I press the button but none when a device is plugged in. Bought from Amazon. Not feeling hopeful I can get it resolved in time. I may need to buy another one and return this one for a refund.

That was going to be my other point was to see if you can 2 day it in time and then return the other one as a defective item.

Before going to extreme, try taking the charging cable and plugging it in to the usb port and the other end into the charge port essentially looping itseld, leave it plugged in for 10 seconds. This will reset the device and with hope reset it internally and allow it to work as it should.

Hope you were able to get your issue resolved.

Have the same model here with a similar situation. In my case, the lights will turn on briefly when a Lightning cable is connected, and charging starts on my iPhone. The lights go out, and charging continues for about 15 seconds. Resetting it with its included charge cable didn’t make a difference; I tried looping out of both USB-A ports. Contacted Anker and got a pleasantly swift reply using their “Process A Warranty” tool. After a review of my troubleshooting steps, they agreed the unit needed replacement. They are sending one today. Only bought this one 3 months ago, so yay warranty!

Mostly leaving this message for the benefit of others who might be Googling around like I was today. If your unit is under warranty, report the issue to Anker without delay. If not, well… spend the extra ~$10 for a nicer model. :grinning: I’m generally an Anker fanboy, but this model seems to have design issues.

Same problem with a unit I bought in Aug/2019. I thought it was bad cables or something. I just wrote support now May/2020 and they are sending me a new unit. that is excellent product support.

I was spending weeks in a hospital and on my phone for everything so I needed a full-day power supply and this worked really well while traveling and walking and talking.