Anker PowerCore 10000 PD Slim not charging via PD

Hey all

I bought a brand new Anker PowerCore Slim 10000 PD portable charger yesterday, along with a RavPower PD Pioneer 30W wall charger. I plugged the Powercore in to the PD port on the wall charger with the USB C cable that was included with the powercore, and left it overnight. It didn’t even charge one bar. This morning I plugged it in via a USB A to USB C cable and the non PD port, and it’s already at 1 1/2 bars. Any thoughts on why PD charging isn’t working?


1 Like

May be you should try another charger.

1 Like

Process of elimination.

Could be the charger, cable or the Powercore.

See if the charger is working with something else PD.

Try different cable.

If you’ve got a verified to work charger with s verified to work cable not charging the Powercore then I’d contact support. Until you’ve test each part separately everyone is guessing.

Make sure when you are plugging in the battery bank to charge that there are no lights on the batterypack, otherwise it will output a charge and not accept the charge

1 Like

I’ve verified that both the wall charger and the cable work with another device (Canon EOS RP), so I know that isn’t the problem. Another user said to make sure there were no lights on the battery pack when I plugged it in, I double checked and that wasn’t happening either. When I plug it in via PD the 1st led blinks twice and then pauses, a few seconds later it repeats.

You need a PD sink to verify the PD protocol is coming from the source. That camera is just USB C.

This is either the charger isn’t output PD, the cable is dud, the power is getting through but not data to use negotiation or the Powercore is dud.

Look for different cables and a PD sink.

1 Like

Actually the camera is not just USB C, it requires a PD power source. That’s the reason that I bought a PD power bank in the first place. Here is a forum post confirming this

Well then on balance of probabilities the Powercore is dud based on your tests.

I’d do one more test which is swap the cable around different ends because it’s more commonly the cable than anything else, and try different cables.

Well, I don’t have another cable but I actually did try different ends and it had the same result. I guess I will reach out to Anker support. Thanks everyone :slight_smile:

Ok, it’s still Thursday so may get resolution tomorrow.

Gather proof of purchase and serial number, description of fault, what you’ve attempted to eliminate, yes you did ensure no lights on before plugging in C cable to PD port of charger and it’s not charging. They will reply with try different cable and charger unless you say you’ve already tried it. You’ll be asked to try another PD charger like an Anker PD charger.


1 Like

They need to send you a replacement because it seems the one you got doesn’t work, good luck

Today I got an email from Anker, and they decided that it was an issue with the Ravpower charger :confused: So they won’t replace it, but they will offer me 20% off of an Anker charger (of course). Should I try to argue with them or just do a return through Amazon and then buy another one?

I would try the ANKER charger.
This will not be a bad decision.
The chargers are perfect.
I use mine since 5 years.
If it doesn’t work you might contact the service again and send all items back.

If you can still return it and get your money back then do that :+1:

1 Like

Well, I would get the Anker one, but it only has 1 USB C port, while the Ravpower one I bought has a USB C and a USB A port, so I can charge multiple devices while traveling.

Will do, thanks for your help

Anker do sell C and A chargers. e.g.

You can still return through Amazon the Powercore and return the Anker charger if you buy one. Your choice.

What some do is return and buy another to eliminate if dud unit. Some just return and give up.

Yes, it is possible an incompatibility, but it’s also possible its a dud unit.

I was going to get one of the Anker chargers but they’re far more expensive if you want dual ports. I’ll probably end up returning and buying another Powercore just to see if that’s the problem. I did confirm that it will output PD, just not charge with it which is weird.

That weirdness is probably Anker is not offering a refund and you use Amazon instead. It could just be a negotiation issue. Some Anker chargers won’t charge some Anker Powercore so even their own products have weird issues.

The fact it gives output but not input gives some idea its not a dud unit, but a return + buy can eliminate dud unit chances.

If the replacement behaves exactly the same then it would point to the RavPower being incompatible or itself fault instead,

1 Like