Anker PowerConf Bluetooth Mic/Speaker Firmware Update Fails on multiple devices

I received the Anker PowerConf yesterday and have spent several hours attempting to upgrade the firmware. I’ve tried my Android phone, downloaded SoundCore, it detects the device and states the firmware is out of date, downloads the firmware but attempts to update fail.
1 - First, I tried using just the Bluetooth and disabled Bluetooth on my PC, and iPhone to assure no conflicts. I verified device is connected and tested the speaker and microphone to make sure device is functional. I downloaded Soundcore application from Google Apps Store. Soundcore detects the device and states the Firmware needs to be updated. Firmware downloads, update fails - every time.
2 - Second, I connect the USB cable from my Android phone to the Anker. Just keeping the defaults, I verify the audio is working, install the Soundcore application, download the firmware - the install procedure fails.
3 - So, I enable the debug options on my Android, turned on USB debugging, set the USB configuration to Charging mode - failed. MTP mode - Failed. PTP mode - Failed. RNDIS Mode - Failed. Audio Source - Failed. MIDI -Failed. Basically, I tried every option available for the USB Configuration.

Normally, just enabling USB Debug option is what you would use to transfer files to and from a PC, for example Tried various other options, all failed.

4 - I remove (forget) the Anker device on the Android phone and disable bluetooth on the Android.
5 - I switch to my iPhone, download Soundcore, turn on Bluetooth, Pair the devices, verify speaker and microphone is working. I launch the Soundcore application, download the firmware, update/install fails.

This is the only option when it comes to iPhone is to use the Bluetooth.

The firmware downloads on Soundcore website appear to be only for certain speakers so I don’t want to risk using one of those options.

However, instead I launch NOX and have USB port redirect turned on. NOX is an Android Emulator for computer that is used to develop phone applications. I run the Android emulator, download Soundcore App, download firmware, update fails.

I’ve read of several scenarios where it is important to update the firmware. Generally, this is something you would do as best practice.

Current firmware on device is 24.38 and new version is 26.47. It needs to be updated.

It is stated to update the firmware but there is no real information on how to do that other than download the Soundcore app on either iPhone or Android - I’ve done both and both failed.

Since updating firmware is important - if this doesn’t get resolved it will be part of my review on Amazon.

Hopefully someone will respond with the right information and there should be more information in the manual or on the website because these hardware level firmware updates can often be critical when it comes to this type of device and algorithms relative to sound quality, background noise, and proper function.

1 Like

Hi @vcissgroup55

Thanks for detailed explanation.

I have been using and testing PowerConf with iPhone and Windows 10 PC
Note that below are the latest versions, as of writing this comment. The new features on SOUNDCORE App and PowerConf firmware are detailed here

  • Latest PowerConf Firmware Version in 26.47.
  • Latest Soundcore App version is v2.0.7 (iOS)

I have updated firmware couple of times, both via iPhone, and seen no issues.

The suggested way to update the firmware on PowerConf is via Soundcore App on your smartphone (iphone in my case) updates happen fairly quick and PowerConf goes through reboot. Believe you already tried this and it has failed.

At this stage, I would suggest you contact Anker Support for response to the issue, they are pretty good and respond within couple of business days.

Give the Anker Support an opportunity to review your issue and get back to you.

Hey @vcissgroup55 shame your having issue.
Just to add to @Shenoy response, I’ve also successfully upgraded mine via the app on a Samsung Android device.

Ive looked online and cant see a button sequence to reset the PowerConf, maybe @AnkerTechnical could confirm this.

I had the same issues trying to update the Firmware, I had to disconnect the USB cable from the computer and then it started to install the Firmware using my iPhone

1 Like