Anker Outdoor Generator 256Wh, 521 Portable Power Station Solar Panel

Good Afternoon,

I’ve reached out to Anker support but I haven’t gotten a response. Does anyone know what Voltage, Amps, and Wattage the MPPT controller can handle along with maximum charging Wattage via solar? Connection size?


1 Like

Disregard, found my own answer, please see below if searching for this information; specs on Anker website (not amazon).

DC Input =11-28V⎓ 5.5A (65W Max)
DC 7909 8mm


Wanted to follow up on this for anyone searching. I ended up purchasing this unit on Amazon. I’m putting it through the paces right now, but wanted to give a bit of a warning for anyone searching for info on the device.

There is no official solar panel for this unit by Anker; however specifications for the Rockpal Solar Panel fit the bill.

It even shows the Anker 521 as being compatible in their description with the 8mm barrel connector. However, it is not compatible; while the barrel is 8mm wide it is roughly 1-2mm too short to make a firm connection with this unit. Rockpals states that Anker is using a non standard 8mm connector in this unit.

I’m working with Rockpals support on this and will be reaching out to Anker support, but buyer beware on using this pair.

1 Like

Nothing a wire cutter stripper and a new connector can’t fix right?

I do have solar but nothing on this scale as bigger needs are rarer needs, I have simpler 67W total solar with regular 5V USB-A outputs for Powercore for phones+tablets+flashlights, and I use ice to store cold. Old cheap slow tech.

Yeah, I could just cut the sheathing and make it work, but I was looking for something a bit more elegant. My solder work is shaky at best.

I’ve ordered a bunch of different adapters and going to give them a go when then come in.

1 Like

I have also purchased a 521 and really like it, but the solar panel connectivity is a challenge. I own an HQST 100W solar panel with MC4 connectors and purchased a BougeRV MC4 to DC 8mm cable to connect the panel and the 521. The polarity and continuity of this cable are correct, but it will not transfer power to the 521. The DC 8mm plug on this cable also looks a bit “shallow” compared to those on the Anker supplied 110 charger and car outlet cable. Making them match would be easily rectified by trimming 2mm of rubber from the end of the plug housing. However, this is not the issue. Rather, the Anker 521 requires both the center pin and the inner sleeve of the 8mm plug to be energized with positive polarity.

Most other portable power stations require only that the inner sleeve be energized with positive polarity. Almost every manufacturer of solar panel adapter cords leaves the center pin “dead”, as my BougeRV cable does. These will not work with the 521. Anker tech support (quickly) responded that their DC 8mm plug is actually a DC7909 - a very similar plug which evidently specifies center pin energy - and that I need to find a cable with a DC 7909 plug, but that they were not able to recommend one. Fine, but this is a distinction the solar products industry simply does not make and therefore is not a practical solution. If Anker wants to be serious about making the 521 appealing to solar users, they need to either 1.) create or partner to develop and sell a line of solar connective cables for their products, 2.) offer a female DC 8mm to male DC7909 adapter plug with an energized center pin or 3.) modify the 521 so that it doesn’t require the center pin to be active.

I haven’t yet decided whether to keep the unit and commit to creating my own cables or return it and purchase a competitive product that was more intentionally developed to work with solar.

1 Like

You are clearly very knowledgeable and know more about solar panels connectors than me.

But your words make no electrical sense. Energy flows through the electromagnetic field directed by a voltage potential difference so there only needs a voltage difference. The photovoltaic effect makes electrons (negative) liberated off a semiconductor which leaves a “hole” ( positive) which is the voltage difference so at any particular time there is a positive and a negative, but there’s also static electrical potential just from many other sources so you can have both pins negative or both pins positive but irrelevant as it’s the voltage difference which drives the system.

If you had both pins positive they’d be sucking in electrons from wherever. So doesn’t make sense.

Not saying you’re wrong. Just someone is wrong.

I was able to get it to work with this Anderson to 8mm adapter:

I tried several but this is the only one that would work with my solar panel and Anker 521; maybe it will be of use to you.

I bought this cable (uk( which works with my 521 hooked up to 100 w Renogy fixed panel. (I get 65 watts from panel on clear mornings SE facing panel)

Has anyone seen any strange behaviour with the power station and charging from solar??

My setup - continuously connected to solar and then just charge devices from the 521 during the day and evening - I get the feeling solar charging and charging devices at same time seems to be messing up the display % - I’ve actually had the 521 show 100% and just instantly drop to 0 during this time when I’ve plugged a device in to charge.

I’m still trying to reset the counter - full charge and discharge from mains power to get % counter to work correctly again - and think I’ll have to solar charge during day and use 521 power in Evenings so there’s no overlap - ANYONE ELSE SEEN THIS TYPE OF BEHAVIOUR??

I’ve not experienced anything like this, but there are some answers in the support FAQ. Give those a go. If that doesn’t resolve then I would recommend to reach out to support:
What should I do if the display only shows 100% and 0% or if the battery discharges quickly within several minutes? (

How to reset Anker 521 Portable Power Station (PowerHouse 256Wh)?

1 Like

Thanks bassline, resetting the device and fully charging through mains overnight a couple more times appears to have solved the biggest issue with display not correctly indicating power available.

Although I did read of another user having issues and he thought it was related to using the power socket with ‘ power saving’ enabled - I’ve not used the power socket and switched off power saving - so it could also be related to this.

1 Like