Anker Model B1374

Hi everyone, maybe one of you may be able to help me.

I have had this model for a while and I am satisfied with the product. However, it came a point where although it charges, when I try to plug a device for it to charge it wont turn on, wont charge anything. I tried using one of the other USB available. Tried to use another charger without much success.
I googled how to troubleshoot, and theres nothing on the subject. I love this brand, I love the power this portable charger gives me.
Anyone have any suggestions on how I may be able to troubleshoot this device.
Thanks a bunch.

Have you tried using a different cable? Perhaps a new cable will net a different result

Not sure what device this is? I’m guessing g a powerbank/wall charger

If a power bank, is it charged?

Also, what device are you charging? A phone, a Nintendo active, even a Huawei phone (these are very fussy and only certain things work with them)

Hi @drmanhattans_balls,

Thanks for contacting us and letting us know your issue.

We regret to hear that this PowerCore+ 26800 battery cannot charge your device and so sorry for any inconvenience caused to you.

To confirm the issue, could you please let us know your device model? Per @amangons’s question and @elmo41683’s suggestion, is it a Nintendo or a phone? Could you please use another working cable and test other devices to see if the problem persists?

If yes, please contact us via and we will be more than happy to help you out as per the 18-month warranty policy.

Sorry for the inconvenience caused and thanks for your understanding.