Anker model A8371 not working after macOS Catalina 10.15.4 update

Yesterday I updated my MacOS to the new macOS Catalina 10.15.4 version, and since then, my Anker model A8371 has not been working.

This model has ports for 1 HDMI cable, 2 USB-C - being 1 for charging, 2 regular USB, and a SD card. It was working fine yesterday, but since the update the only thing that works is the USB-C for charging the mac.

The moment I updated my mac the only ports being used were the USB-C for charging and the HDMI port.

Is there something that I can do to solve this?
Please help.

hey, did you get it solved?

Thank you for bringing this issue to our attention via the community.

Please try driver in link:

If the issue still persists, you can contact us via and we will be more than happy to help you out as per the 18-month warranty policy.

Sorry for the inconvenience caused and thanks for your understanding.

Hey, yeah I did

I just had to unplug the hub, plug it upside down and restart my mac. Then i unpluged the hub again, reppluged it in the normal position and it worked.

Hope it helps somebody