anker mars II wont charge


I’ve bought a Mars 2 pro and it wont charge. its got what I think is a 2 pronged European plug, the same as a UK shaving/electric tooth brush plug end. I’ve tried using an adapter that I use for the toothbrush but it wont charge.

does anyone know what I can do?


Do you have a phase checker to find out if there is any voltage at the end of the cable?
UK got other plugs and sockets than the EU

1 Like

Adapters are very simply physical items which tend to work, but what usually happens is the slightly springy metal inside is too wide for some pins and you’re not getting a reliable (or any connection). Sometimes a wiggle jiggle can get a just-about-works result. A couple of times in my life the adapter I had to screwdriver open (not plugged in obviously!) and bend oval shaped metal back (then screwdriver close) to return to a reliable connection, as simple free fix.

So go through a process or elimination.

Does the adapter work with something else? If it does, then do the Mars 2 pro charger pins look different from whatever else you tried (shorter, narrower)?

The PSU (the charger with the 2 pins) is not a simple thing, it’s doing AC/DC conversion and is more likely than the adapter to be at fault. What’s the DC voltage for the projector? You might be lucky and find same polarity, voltage and sufficient current, to see see if its the PSU.

Finally, you have support also

This here is a community of users primarily where we may know of fixes, where prior threads a user reported a solution and we happen to remember it, but it isn’t here really a support site which Nebula intensely scans. If you can, you should had tagged this Nebula not Anker but doubt that will get support faster (future reference).

Also note the support tends to be dominated by Chinese working hours and it’s now their weekend so you may not get a support reply til Monday.