Anker Jump Starter not working

Bought the Anker Compact Car Jump Starter two years ago, fortunately never had to use it until today. Turning the unit on and plugging the jump connectors to it just cause the green and red lights to blink. Then tried to plug it into the car battery and same green and red lights blinking. Left my car and called an uber to at least get to work.

Are there any tricks to get this to work? Tried to call customer support but they are not open yet in EST.

Sucks the only time I needed to use this was in an emergency that didn’t come until after the warranties ran out :frowning:

When was the last time you charged it? Batterypacks can generally hold a charge for a while, but 2 years it would have depleted that charge. Have you tried charging it up and trying again?

ive had mine since 2015, still works great. Used it 2 weeks ago to help someone with a dead battery.
Did you try charging it overnight? Have you hooked it to your car battery and put key in accessory mode to see if LED changes?

Hi @inactiveRC,

Thank you for bringing this issue to our attention via the community.

We are sorry to hear that you are having problems with your Anker jump starter. As suggested by @elmo41683 and @bill_rae, could you please recharge the Anker jump starter to full and then try to jump the car with the following steps?

  1. Make sure the red clamp be connected to"+" end and black clamp to "-"end of the car battery?

  2. Please turn on your car headlights (to low down your car battery’s voltage) and try to jump start your car again after 30 seconds. The LED light on the jumper cable wouldn’t turn green if your car battery’s voltage is higher than our jump starter’s voltage and therefore you’re unable to jump start your car.

  3. Move the ‘-’ cable from the car battery, then connect the black clamp to the ‘-’ cable directly, and the red clamp still connected to"+" end. Turn on your car headlights, and press the reset button for seconds. Try to start your car again!

Know that the Anker Compact Car Jump Starter can only jump 3L gas(Max.) or 2.5L diesel(Max.) vehicle engine. Please make sure your car’s engine is within the specs.

Hope this is helpful. Thanks for your support.

1 Like

I have Anker A1501 which has a similar problem. When I plug in the jump start leads the green and red lights blink simultaneously, without being connected to anything, and stayed that way when connected to the dead car battery. The unit does not seem to be delivering any power to the car, so I had to summon a breakdown truck to start it. I bought this unit a bit over 3 years ago, and have not needed to use it till now - so it failed at the first test. I checked the charge status, and that was fine, and for good measure I fully charged it over night, but the unit is still not working. Sadly, there does not seem to be anything to do but throw it away.

Mine is the Anker Model A1501 and it experiences the same behavior: the red and green lights blink as soon as I plug in the cable and continue to do so after I’ve connected the cable to my auto battery. It was fully charged. I tried cranking my car anyway, and it worked, despite the blinking lights.

Is it still under warranty? I’d recommend you to contact support directly

I have 3 of A1501 model chargers. NONE of them work!!! I’ve owned them for maybe 4 years now and charge them every 3 - 6 months. Out of the 3 of them, I might have used them maybe 4 -5 times total.
I tried using them last week on one car. The first one I tried would never get to just the green light. I tried anyway and the engine didn’t turn at all and soon I heard the unit beep continuously until I pulled the cable out. Then it showed no bars. The second one I tried also didn’t go green. Tried anyway. No engine turn. Then it turned green. Still no engine turn again. Went to no bars. Beeping. The third one went green after connection to the battery. Finally! One that works. But no engine turn! stayed green. Tried again. Same result. Beeping. No bars. Also tried holding the power button down for 5 seconds and tried again. No difference.
So, maybe the energy bars weren’t accurate. Plugged them into the wall charger. Immediately each of them showed 5 bars. Unplugged them right away to see how many bars while unplugged. 4 bars each and the flashlight worked whereas before it didn’t. So apparently the bars were accurate before trying to use them. Simply, the stupid chargers didn’t want to work.
Even when new, I had varying degrees of success with them where sometimes it didn’t go green but eventually did. This time, no dice at all. I’m upset since I have been buying Anker cables and chargers for a long time and thought that I finally found a company that was different, with a longer warranty that proved that they believed in their products and made quality ones, unlike the cheap Asian knockoffs. Well, the cables and other light stuff are good, but these jump starters are just crap. I can see why they don’t really market them much anymore and don’t have as many models as they used too. They clearly have had problems with them. I just feel bad that I recommended them to all my friends who didn’t know that these things could replace jumper cables. I hope I don’t leave them stranded by the road. Luckily, I was at home!
I actually finally got my car started with my fourth jumper, another very popular brand on Amazon. Not one glitch. I’ll be buying 3 more of those. I now have $200 worth of giant battery packs at home. Hopefully they’ll work with phones and tablets.
Btw, it was a 2015 Toyota Rav 4 with a 2.5 liter engine.