Anker A7721 - No longer typing letters, only numbers

The Anker A7721 has been a pretty good little keyboard for me. Has worked on my Samsung android devices and my RaspberryPi.

Problem though, today I turned on the keyboard and connected to the Pi, but the keyboard would not output any letters. There seems to be no response from any keys except 987-UJM-IK,-OL. When you hit these keys it displays numbers and number pad types of things like + and *. Is there a weird function that’s been activated? Anyone else had this happen before? Tried removing the device and readding it, but nothing changed.


Is it only doing it on the Pi and do any keys look like they are still depressed/stuck down on the keyboard?

That sort of behavior is similar to when either the num lock or function key is pressed on Windows (for keys that have more than a single function) yet from what I can see on the manual, this doesn’t have a num lock key/

Would advise dropping an email (should you be inside your 18 month warranty) if the behavior is also present on another device and the keys seem fine.

Yea, everything looks good. The keyboard is pretty pristine and it’s only happening on the Pi, so not sure why it all of a sudden stopped working. Pretty frustrating since I bought it for the Pi specifically. The other devices were just a nice bonus. I literally threw away the boxes yesterday because I was convinced I’d be sticking with this device.

If it’s only happening on the Pi it sounds like a recent configuration change has messed some settings up. I don’t have one myself so I’m a bit limited on what to suggest to resolve. A few posts on the form has a few workarounds for key mixups, might be worth a look for troubleshooting;

Dear Mark_Ferreira,

We are sorry for inconvenience caused to you by our keyboard. Could you please fully charge the keyboard for more than 3 hours and cancel all paring records then reconnect?

If no avail, please contact us via together with your order number.

1 Like

I know this post is old, but I’ve run into the same issue with my pixel phone: my A7721 works well (still!) on all my devices except that one, but it now acts as a number pad when talking to that device (and it used to work there too). Media keys and so on still work, but they’re not as labeled: “lower volume” actually raises the volume, etc.

I’ve tried charging the keyboard and re-pairing, as suggested, and I’ve changed the keymap several times, to several values, in the settings, but no luck so far. Has anyone been able to get the keyboard out of this mode? Like I said, the keyboard works on other computers, and other keyboards (including this one previously) work with the phone, so the problem seems like it must be fairly superficial, but I just can’t figure out how to fix it. Has anyone else had any luck?

I do not have either… Tru the simplest first. I know a lot of folks do not restart phones. Try to restart to see if it is an issue with the phone.

Same problem, with both my pixel phone and my husband’s. He said it went into that mode after he thought it wasn’t connecting and pressed a lot of keys at once. I’ve tried a lot of things, including removing the key cap to check for stuck key. No luck.

Interestingly, it works fine on my macbook pro, just not on the pixel phones!

Pixel 3axl. Keyboard recently stopped working with my Google phone. The keyboard works on my husband’s Motorola phone, my MacBook Pro. Any suggestions of what to do? I’ve had the keyboard since 2015.

Me too. Pixel 4a. The keyboard worked flawlessly for years, including with this phone.

I notice that everyone with problems has a pixel, so maybe an OS update broke something.

This appears to have been fixed in Android 13.