Anker 536 USB-C Dock & M1 MacBook Air: no video output

Brand-new Anker 536 USB-C dock, DisplayLink application installed, and macOS 12.4 on the M1 Air. Connected up and worked fine for one day. Next morning, no video output from the dock at all - monitors briefly act like they know they are connected but go to sleep after no video received from dock. Reboots and DisplayLink reinstall to no change. Also, the Air is not receiving power from the 100W port on the dock via either USB-C port on the Air. Thoughts?

Not many own that product who will reply here so put email to

While you wait for their reply, I’d not do a reboot, I’d turn everything off, then plug the docking station in with all the accesories, turn on and see if working, if still not then unplug and reconnect the displays.

I’d also double-check power is working to the dock. It is more common for PSUs to fail than electronic to fail, I’d look for whatever lights come on when powering the dock to be sure the PSU is working (PSU = the part which plugs into wall socket, check it feels warm so it’s getting power).

1 Like

I would contact the service.
As it is a brand new item it is under warranty.
Don’t forget to add all the “numbers” you find on device and the packaging.


Agreed with the rest. I had thought about checking for something similar for son’s devices but never went to get anything for them as they never stated any real need for it.

1 Like