Anker 4-Port Ultraslim USB Hub interfering with Logitech Unifying Receiver

I recently purchased an Anker 4-port USB Hub; I noticed after I plugged it in to the back of my Mac Mini, that I was having connectivity issues with my wireless mouse. Then I moved the unifying receiver to the Anker USB Hub and the mouse seemed to work better, but I started intermittently losing connection to my wireless keyboard.

Unplugging the hub seems to be the only way that both of those peripherals work without issue. I have updated the Logitech firmware and reinstalled the Logitech software, but it still doesn’t resolve the issue.

Any suggestions on how to fix this problem?

So sorry to know you have trouble using your wireless devices with your hub.

Please know that Bluetooth devices (such as a wireless mouse or keyboard) use a specific radio frequency to talk to each other. It’s a bit like the old AM/FM radios but at a much higher frequency that humans can’t hear.

USB 3.0 devices naturally use cables, however, the cables and the devices connected at each end generate electrical noise over a range of radio frequencies. Unfortunately, the range of frequencies USB 3.0 is allowed to use conflicts with the specific frequency all Bluetooth devices use. This means that any USB 3.0 port, cable or USB 3.0 device can emit radio frequencies that may cause interference with any Bluetooth devices you use in your computer.

The end result is that your Bluetooth device(s) may degrade in performance, like what you are experiencing. To help inform buyers about this, we put the following information in the product’s listing information:

“2.4 GHz wireless devices, MIDI devices and some USB 3.0 devices may not be supported. Try using the host port or a USB 2.0 connection.”

Currently, it is a general issue for USB 3.0 devices. It may help if you use an extension USB cable for this USB 3.0 hub or you can try a wired device if you have one.

We hope you find this information helpful. For any other questions or concerns please do not hesitate to contact us–we’re always here to help.

Hey! I was having the same issues, but with a wired mouse and keyboard which were both connected to the Anker 4-port. Unfortunately, I am running a Windows PC, but the underlying problem concept may be worth exploring.

I fixed the issue by going to the Power Management section of my USB Root Hub device and unchecking the box that allows Windows to turn it off when it needs to save power.

I found a possible fix for Mac on this website, again, take it with a grain of salt, it may not end up being the same issue:

Another possible way to research the issue is to search this on Google and go from there: mac usb root hub power options

Hope this helps, cheers!

I have the same problem with a 2.4GHZ wireless keyboard and mouse used in conjunction with Anker USB3 hub.
The problem remains even with the wireless dongle plugged straight in my computer, unless I unplug the Anker hub.
I may try moving the Anker hub away from the computer but I’ll need a usb extension to do that.
I wish I had known about this issue before.

I was having this same exact issue. USB hub plugged into MBP that only has USB-C ports. Needed to run my Logitech unifying receiver off it, and was having terrible connection issues, missed keystrokes and dropped connections between the devices and the computer.

Added a 3ft long USB extension cable (like $8 on Amazon, next day delivery) and it’s solved my issue entirely. Can use the keyboard from across the room if I wanted to. Hasn’t missed a step.