Anker 4-Port UltraSlim USB 3.0 Data Hub


I need urgent assistance. In our studio we have a Windows 7 desktop and the usb data hub says that it is not being recognized/not working properly with Windows. It’s always worked before and power seems to be going from the hub to the devices, however these just don’t seem to be recognised anymore. I looked at the drivers through Microsoft but it seems like that doesn’t seem to be the problem as it said they were updated and automatically installed. Also tested the hub on a laptop and it worked fine. What are the reasons for this malfunction, but most importantly how can I fix it?


generally when ports do not work, restarting the device gets it working again

I agree with @Tank. When I’m dealing with a non working port that was working fine a few minutes ago even the last time the computer is on something caused the port to shut down. A program crashed, firmware failed to load.

Windows computers need to be rebooted often. Working with clients computers, family, and friends computers I rarely saw a hardware fail for the port unless the port was damaged due someone bumping the USB cable to hard or putting the USB cable in the wrong direction.

I’ve also seen USB cable failing. One minute they were working and the next they weren’t.

If you haven’t already I would try another port. Also, if its a port on the case and not a port directly on the motherboard, make sure the extension cable between the case port and the motherboard is connected properly (it could have also gone bad).