Anker 3.0 Card Reader not working in Anker 3.0 USB Hub

I have an odd problem.

I have 2 Anker USB 3.0 SD/microSD card readers. They work perfectly when plugged directly into the computer or into my Targus USB 2.0 hub.

They will not work, however, when plugged into the Anker USB 3.0 hub. My first thought is that I simply got a defective USB hub, but the replacement doesn’t work with the SD card readers either. A standard USB thumb drive, however, works perfectly in the Anker hub.

So - the SD card reader works the way it should.
The USB hub is working (at least with standard USB thumb drives) the way it should.

So - why won’t they work with each other? Both are Anker products.

The model numbers of the products:
SD Card Reader - Anker AR200
USB 3.0 hub - Anker A7516


Update - on a whim, I tried an old no brand name or model number on the unit probably came from Big Lots USB 2.0 SD card reader in the Anker hub. It worked perfectly., so it doesn’t appear to be an issue with SD card readers in and of themselves.

Sorry can’t help here, don’t own, but I am seeing these strange bugs like with MacBook and keyboards.

I’m developing a theory this is related to versions of USB, if you mix them in a hub it breaks it.

I emailed Anker customer support as well. Their response - to unplug every USB device from my computer, wait 5 minutes and then try again.

Yes, that fixed it for now. But I had the same problem with two different hubs of the exact same model, so I’m not confident that the fix is permanent - and pulling my computer out of it’s niche and unplug all the USBs every time the hub wants to act up is not a reasonable fix.

They asked for the model numbers and copies of my invoices, so who knows what they’re planning on doing.

1 Like